WordPress.org

Making WordPress.org


Ignore:
Timestamp:
09/21/2017 07:10:15 PM (3 years ago)
Author:
coffee2code
Message:

Browse Happy API: Mark versions of Internet Explorer earlier than 11 as insecure.

  • Adds IE 10 & 11 user-agent strings to test data
  • Adds unit test for insecure browsers (currently just testing for IE)

Props SergeyBiryukov.
Fixes #2587.
Fixes #core40165.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0/parse.php

    r5935 r5949  
    110110    $data['current_version'] = get_browser_version_from_name( $data['name'] );
    111111    $data['upgrade']         = ( ! empty( $data['current_version'] ) && version_compare( $data['version'], $data['current_version'], '<' ) );
    112     $data['insecure']        = ( 'Internet Explorer' == $data['name'] && version_compare( $data['version'], '8', '<' ) );
     112    $data['insecure']        = ( 'Internet Explorer' == $data['name'] && version_compare( $data['version'], '11', '<' ) );
    113113
    114114    return $data;
Note: See TracChangeset for help on using the changeset viewer.