WordPress.org

Making WordPress.org


Ignore:
Timestamp:
09/28/2017 10:38:09 PM (2 years ago)
Author:
coffee2code
Message:

Browse Happy API: Bump current version of Safari to 11 and mark versions earlier than 10 as insecure.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0/tests/phpunit/tests/browse-happy.php

    r5974 r5975  
    461461        } elseif ( 'Opera' === $parsed['name'] && version_compare( $parsed['version'], '12.18', '<' ) ) {
    462462            $this->assertTrue( $parsed['insecure'] );
     463        } elseif ( 'Safari' === $parsed['name'] && version_compare( $parsed['version'], '10', '<' ) && ! $parsed['mobile'] ) {
     464            $this->assertTrue( $parsed['insecure'] );
    463465        } else {
    464466            $this->assertFalse( $parsed['insecure'] );
Note: See TracChangeset for help on using the changeset viewer.