WordPress.org

Making WordPress.org

Changeset 5976


Ignore:
Timestamp:
09/28/2017 10:42:19 PM (22 months ago)
Author:
coffee2code
Message:

Browse Happy API: Bump current version of Firefox to 56 and mark versions earlier than 52 (latest Extended Support Release) as insecure.

End of life for v52.x.x ESR scheduled for 2018-06-28.

Location:
sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0/browsers.php

    r5975 r5976  
    1919    return array(
    2020        'Chrome'            => '18', // Lowest version at the moment (mobile)
    21         'Firefox'           => '16',
     21        'Firefox'           => '56',
    2222        'Microsoft Edge'    => '15.15063',
    2323        'Opera'             => '12.18',
  • sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0/parse.php

    r5975 r5976  
    161161    if ( 'Internet Explorer' === $data['name'] && version_compare( $data['version'], '11', '<' ) ) {
    162162        $data['insecure'] = true;
     163    } elseif ( 'Firefox' === $data['name'] && version_compare( $data['version'], '52', '<' ) ) {
     164        $data['insecure'] = true;
    163165    } elseif ( 'Opera' === $data['name'] && version_compare( $data['version'], '12.18', '<' ) ) {
    164166        $data['insecure'] = true;
  • sites/trunk/api.wordpress.org/public_html/core/browse-happy/1.0/tests/phpunit/tests/browse-happy.php

    r5975 r5976  
    459459        if ( 'Internet Explorer' === $parsed['name'] && version_compare( $parsed['version'], '11', '<' ) ) {
    460460            $this->assertTrue( $parsed['insecure'] );
     461        } elseif ( 'Firefox' === $parsed['name'] && version_compare( $parsed['version'], '52', '<' ) ) {
     462            $this->assertTrue( $parsed['insecure'] );
    461463        } elseif ( 'Opera' === $parsed['name'] && version_compare( $parsed['version'], '12.18', '<' ) ) {
    462464            $this->assertTrue( $parsed['insecure'] );
Note: See TracChangeset for help on using the changeset viewer.