WordPress.org

Making WordPress.org

Changeset 7631


Ignore:
Timestamp:
08/24/2018 06:36:08 AM (3 years ago)
Author:
obenland
Message:

Plugins: Convey that it's a minimum required version

Fixes #3574.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/widgets/class-meta.php

    r7196 r7631  
    8888            <?php if ( $requires = (string) get_post_meta( $post->ID, 'requires', true ) ) : ?>
    8989                <li>
    90                     <?php
    91                     printf(
    92                         /* translators: %s: version number */
    93                         __( 'Requires WordPress Version: %s', 'wporg-plugins' ),
    94                         '<strong>' . esc_html( $requires ) . '</strong>'
    95                     );
    96                     ?>
     90                    <?php esc_html_e( 'WordPress Version:', 'wporg-plugins' ); ?>
     91                    <strong>
     92                        <?php
     93                        printf(
     94                            /* translators: Minimum version number required. */
     95                            esc_html__( '%s or higher', 'wporg-plugins' ),
     96                            esc_html( $requires )
     97                        );
     98                        ?>
     99                    </strong>
    97100                </li>
    98101            <?php endif; ?>
     
    112115            <?php if ( $requires_php = (string) get_post_meta( $post->ID, 'requires_php', true ) ) : ?>
    113116                <li>
    114                     <?php
    115                     printf(
    116                         /* translators: %s: version number */
    117                         __( 'Requires PHP Version: %s', 'wporg-plugins' ),
    118                         '<strong>' . esc_html( $requires_php ) . '</strong>'
    119                     );
    120                     ?>
     117                    <?php esc_html_e( 'PHP Version:', 'wporg-plugins' ); ?>
     118                    <strong>
     119                        <?php
     120                        printf(
     121                            /* translators: Minimum version number required. */
     122                            esc_html__( '%s or higher', 'wporg-plugins' ),
     123                            esc_html( $requires_php )
     124                        );
     125                        ?>
     126                    </strong>
    121127                </li>
    122128            <?php endif; ?>
Note: See TracChangeset for help on using the changeset viewer.