WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 3 years ago

Last modified 17 months ago

#1063 closed defect (maybelater)

translate.wordpress.org search is case-sensitive for non-English keywords

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: low
Component: Translate Site & Plugins Keywords:
Cc:

Description

The term name cannot be empty.Название элемента не может быть пустым.
Site Title & TaglineНазвание и описание сайта
New Link Category NameНазвание новой рубрики ссылок
New Category NameНазвание новой рубрики
New Tag NameНазвание новой метки
Software NameНазвание платформы
Site TitleНазвание сайта
A name is required for this termТребуется название этого элемента

I could not reproduce this on a standalone GlotPress install, so it appears to be specific to translate.wordpress.org.

Change History (9)

#2 @ocean90
4 years ago

That's because we're using latin1.

#3 @SergeyBiryukov
4 years ago

I figured as much :) Any way to convert to UTF-8?

Having different results for the same term depending on the case is very unintuitive.

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


4 years ago

#5 @ocean90
3 years ago

  • Priority changed from normal to low

#6 @ocean90
3 years ago

  • Resolution set to maybelater
  • Status changed from new to closed

There are currently no plans for changing the charset to UTF-8, closing as maybelater,

#7 @SergeyBiryukov
2 years ago

The "Case sensitive" checkbox should at least be disabled for non-Latin locales then, because it's currently misleading: the search is always case-sensitive for them, regardless of the checkbox.

#8 @sevlad
2 years ago

I've also noticed that search on translate.wordpress.org is case-sensitive for Cyrillic, even if the checkbox is left unchecked.
For example, "Главной" is not displayed when searching for "главной", and vice versa.

There are currently no plans for changing the charset to UTF-8, closing as maybelater,

Any chance to reconsider that?

#9 @tobifjellner
17 months ago

The same issue happens in Swedish, if the search keyword contains the specific Swedish characters ( åäö vs. ÅÄÖ).

Note: See TracTickets for help on using tickets.