WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#1105 closed enhancement (fixed)

Plugin Directory - change plugin page titles

Reported by: joostdevalk Owned by: coffee2code
Milestone: Priority: normal
Component: Plugin Directory Keywords: dev-feedback has-patch
Cc:

Description

any chance of us changing the titles on plugin pages to something slightly less stupid?

WordPress › %%pluginname%% « WordPress Plugins

feels rather redundant. I propose we just do this:

%%pluginname%% — WordPress Plugins

Attachments (3)

meta-1105.patch (830 bytes) - added by ramiy 4 years ago.
change theme page title
meta-1105.2.patch (869 bytes) - added by SergeyBiryukov 4 years ago.
meta-1105.3.patch (869 bytes) - added by ramiy 4 years ago.

Download all attachments as: .zip

Change History (24)

#1 @kidsguide
4 years ago

  • Cc mpsplugins@… added

This is a good idea. The title is junky and redundant.

Last edited 4 years ago by kidsguide (previous) (diff)

#3 @kidsguide
4 years ago

  • Keywords dev-feedback added

#4 @ramiy
4 years ago

#1264 was marked as a duplicate.

#5 @johnbillion
4 years ago

  • Summary changed from Change titles of plugin pages to Change and localise titles of plugin pages

As per #1264, they need localising too.

#6 @ramiy
4 years ago

  • Summary changed from Change and localise titles of plugin pages to Plugin Directory - change plugin page titles

I have a patch, but it's for theme pages.

@ramiy
4 years ago

change theme page title

#7 @SergeyBiryukov
4 years ago

  • Keywords has-patch added; needs-patch removed

Switching › to » doesn't make much sense to me :) I think the point was to get rid of the first part altogether.

Let's also add a translator comment while we're there, see meta-1105.2.patch.

#8 @ramiy
4 years ago

@SergeyBiryukov, I have access only to the theme repo files. Do you have access to the plugin repo? can you make the same change in plugin pages?

#9 @SergeyBiryukov
4 years ago

Nope, I don't have access to plugin directory either. (Would love to contribute to dotorg though.)

#10 @coffee2code
4 years ago

The solution, while not difficult, is not as clearcut as it may appear.

The issue is that WordPress.org has a global filter on page titles which prepends WordPress › to basically every page title everywhere. The Theme Directory is actually currently exempt from this because it already explicitly adds that in. But if it is removed or changed (as proposed in the two initial patches), the global filter will prepend it to whatever is defined.

Ideally we should come up with a page title format for all of dotorg and see about adjusting the titles and the global title filter accordingly.

The global filter exists to ensure that all titles identify as "WordPress". It could be changed to append something like — WordPress, which would suggest a page title format of:

%%plugin_name%% — %%section%% — WordPress

where %%section%% is "Plugins" (and elsewhere "Themes", "News", "Support", etc). If that syntax sucks, then it could be made to only append if the last segment of the title doesn't already have "WordPress" in it, which could get us what @joostdevalk proposed. I'm not sure if his proposal is the ideal page title format for modern times, or something he settled on relative to what is currently output.

#11 follow-up: @joostdevalk
4 years ago

Couple of remarks:

  • I think we should identify as sections, so "WordPress Plugins", otherwise the .org rankings for those terms would tumble
  • Why —? Google cuts off by length, so I prefer separators that are nice and short, like •

So I'd go for:

%%plugin_name%% • WordPress %%section%%

This same template would work for Themes, News etc. Added benefit is having only one separator, which increases readability in search results pages, which in turn increases click through :)

#12 in reply to: ↑ 11 @coffee2code
4 years ago

Replying to joostdevalk:

  • Why —? Google cuts off by length, so I prefer separators that are nice and short, like •

I'm not particular about choice of separator. Why not | and save even more characters?

#13 @joostdevalk
4 years ago

Because | has readability implications.

#14 @samuelsidler
4 years ago

Beauty is in the eye of the beholder and all that, but I much prefer » (») to •, even if it's slightly larger.

Either way, comment 11 seems like a good way to go. We should standardize this globally though, after the plugin directory title is fixed. (The theme directory is currently "WordPress > %%theme_name%% « Free WordPress Themes" ...)

#15 @ramiy
4 years ago

Related: #1280 - <title> tags on translate.wordpress.org

#16 @ramiy
4 years ago

The main advantage in &mdash;(—) and &bull; (•) over &raquo; (»), &laquo; («), &rsaquo; (›), &lsaquo; (‹) is that dashes and bullets are direction-free, they are suitable for LTR and RTL languages.

Last edited 4 years ago by ramiy (previous) (diff)

This ticket was mentioned in Slack in #meta by sam. View the logs.


4 years ago

#18 @samuelsidler
4 years ago

  • Owner set to coffee2code
  • Status changed from new to assigned

Going with &mdash;.

@ramiy
4 years ago

#19 @coffee2code
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [dotorg-11539] and [dotorg-11540].

Any existing less-than-desirable document titles should be opened as new tickets.

#21 @obenland
3 years ago

In 5203:

Plugin Directory: Use a SEO-optimized site name for titles.

See #1105.
Fixes #2387.

Note: See TracTickets for help on using tickets.