WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 5 years ago

Last modified 12 months ago

#12 closed defect (fixed)

The 'Modify Ticket' section closes during automatic preview

Reported by: johnbillion Owned by: nacin
Milestone: Priority: low
Component: Trac Keywords:
Cc:

Description

Steps to reproduce:

  1. View an existing ticket, and expand the 'Modify Ticket' section at the bottom.
  2. When the automatic preview AJAX thing fires, this section collapses.
  3. Pull hair out and expand the section again.

Change History (6)

#1 @nacin
6 years ago

We manually expand Modify Ticket via JS, after Trac manually collapses it. We might just be able to override the JS that collapses it to begin with and get rid of our own code... Or, force !important !very-important it to always be shown.

#2 follow-up: @bpetty
6 years ago

Related to this, I've been very annoyed with the attachments section being closed by default in several places since the last upgrade too.

#3 @SergeyBiryukov
6 years ago

Yes, having to expand the "Modify Ticket" section is annoying.

On the other hand, having the comment preview right after the textarea itself (without scrolling) is convenient.

Could we perhaps move the "Modify Ticket" section before "Add Comment" (or after the comment preview)?

#4 @nacin
5 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 181:

Trac: Prevent live comment previews from messing with the 'Modify Ticket' collapse/expand state. Move previews to just below the comment field.

fixes #12.

#5 in reply to: ↑ 2 @nacin
5 years ago

Replying to bpetty:

Related to this, I've been very annoyed with the attachments section being closed by default in several places since the last upgrade too.

I haven't seen this occur, but if it does, it should be pretty easy to fix.

This ticket was mentioned in Slack in #meta-tracdev by obenland. View the logs.


12 months ago

Note: See TracTickets for help on using tickets.