WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

#1224 closed enhancement (fixed)

Trac title for component maintainers

Reported by: knutsp Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

We have "Lead Developer", "Core Committer" and "X.x Release Lead". Even if titles/ranks in an opens source project should not be too prominent (we are are contributors, like "soldiers") it's also quite useful for us who comment and contribute now and then to know what the role others have, if any.

With roles/titles there are capabilities and responsibilities connected, like the capability to milestone a ticket and/or the responsibility to maintain tickets in a specific component. Knowing this, without having to search for blog post on Make, could guide the conversation into being even more constructive.

Change History (10)

#1 in reply to: ↑ description ; follow-up: @netweb
4 years ago

  • Keywords good-first-bug added; 2nd-opinion removed

I asked this in #meta on Slack a while ago and never got around to creating a ticket:

Original discussion and question posed: https://wordpress.slack.com/archives/meta/p1423782355001052

netweb: Related: Could/should/would adding custom titles for component maintainers be helpful/useful/meh ?

And Nacin's follow up reply: https://wordpress.slack.com/archives/meta/p1424018616001145

nacin: @netweb: I think we should do them, fwiw. I just haven't yet. :simple_smile:


It's only been recently made possible via r1805 but should be relatively straight forward:

The file to update: /sites/trunk/trac.wordpress.org/templates/core/site-specific.html
The list of component maintainers: https://make.wordpress.org/core/components/

#2 in reply to: ↑ 1 @samuelsidler
4 years ago

  • Keywords good-first-bug removed

Replying to netweb:

The file to update: /sites/trunk/trac.wordpress.org/templates/core/site-specific.html
The list of component maintainers: https://make.wordpress.org/core/components/

Please don't just do this manually. This should be automated so when a new component maintainer is added, it accounts for that. I don't think this is a good first bug either.

#3 @nacin
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Done in [1963], [1965].

#4 follow-up: @netweb
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

As awesome as these are the "Component Maintainer" is not displayed on iOS devices, if using Chrome and emulating an iPhone or iPad via inspector they do work as expected.

Relevant source code from remote iPad Safari debug inspector for comments #47 and #48 of ticket #WP29792

Comment #47:

<div class="change" id="trac-change-47-1443523395641098">
    <h3 class="change">
    <span class="threading">
      <span id="comment:47" class="cnum">
    <a href="#comment:47">#47</a>
  </span>
    </span>
        <span class="avatar">
          <span class="username-line"><a href="//profiles.wordpress.org/netweb" class="profile-link">
            <img src="//wordpress.org/grav-redirect.php?user=netweb&amp;s=48" srcset="//wordpress.org/grav-redirect.php?user=netweb&amp;s=96 2x" height="48" width="48"> @<span class="username" data-username="netweb">netweb</span></a></span>
            <br><span class="time-ago"><a class="timeline" href="/timeline?from=2015-09-29T10%3A43%3A15Z&amp;precision=second" title="See timeline at 09/29/15 10:43:15">13 days</a> ago</span>
        </span>
    <div class="trac-ticket-buttons">
    </div>
  </h3>
    <div class="comment searchable">
        <p>
            I'll work up a fresh patch that should give us an idea of where we're sitting in relation to both what we're looking at for the tooling side and for the CSS changes.
            <br>
        </p>
        <p>
            At the same time, I'll include feedback from both your Helen and Nacin comments <a href="https://core.trac.wordpress.org/ticket/29792#comment:42">comment:42</a> and <a href="https://core.trac.wordpress.org/ticket/29792#comment:40">comment:40</a> respectively with some answers and/or stats based on the issues/questions you both raised.
            <br>
        </p>
    </div>
</div>

Comment #48:

<div class="change" id="trac-change-48-1444579888583545">
    <h3 class="change">
    <span class="threading">
      <span id="comment:48" class="cnum">
    <a href="#comment:48">#48</a>
  </span>
    </span>
        <span class="avatar">
          <span class="username-line"><a href="//profiles.wordpress.org/DrewAPicture" class="profile-link">
            <img src="//wordpress.org/grav-redirect.php?user=DrewAPicture&amp;s=48" srcset="//wordpress.org/grav-redirect.php?user=DrewAPicture&amp;s=96 2x" height="48" width="48"> @<span class="username" data-username="DrewAPicture">DrewAPicture</span></a><span class="contributor-label">Docs Committer</span></span>
            <br><span class="time-ago"><a class="timeline" href="/timeline?from=2015-10-11T16%3A11%3A28Z&amp;precision=second" title="See timeline at 10/11/15 16:11:28">13 hours</a> ago</span>
        </span>
    <div class="trac-ticket-buttons">
    </div>
  </h3>
    <ul class="changes">
        <li class="trac-field-keywords">
            <strong class="trac-field-keywords">Keywords</strong>
            <em>needs-patch</em> added
        </li>
    </ul>
    <div class="comment searchable">
        <p> <a class="mention" href="https://profiles.wordpress.org/netweb">@netweb</a> Any word on an updated patch per your <a class="assigned" href="/ticket/29792#comment:47" title="Comment 47 for Ticket #29792">comment:47</a>? 4.4 Beta1 is looming (Oct. 21).
            <br>
        </p>
    </div>
</div>

I've read through the JS changes in r1963 numerous times but I cannot pick up the cause of the issue:

iOS: `

<span class="username-line"><a href="//profiles.wordpress.org/netweb" class="profile-link">
            <img src="//wordpress.org/grav-redirect.php?user=netweb&amp;s=48" srcset="//wordpress.org/grav-redirect.php?user=netweb&amp;s=96 2x" height="48" width="48"> @<span class="username" data-username="netweb">netweb</span></a>
</span>

Chrome Desktop:

<span class="username-line"><a href="//profiles.wordpress.org/netweb" class="profile-link">
            <img src="//wordpress.org/grav-redirect.php?user=netweb&amp;s=48" srcset="//wordpress.org/grav-redirect.php?user=netweb&amp;s=96 2x" height="48" width="48"> @<span class="username" data-username="netweb">netweb</span></a><span class="contributor-label" title="@netweb maintains the Build/Test Tools component">Component Maintainer</span></span>

This ticket was mentioned in Slack in #meta-tracdev by netweb. View the logs.


4 years ago

#6 in reply to: ↑ 4 ; follow-up: @ocean90
4 years ago

Replying to netweb:
You have to be logged in…

#7 in reply to: ↑ 6 ; follow-up: @netweb
4 years ago

Replying to ocean90:

Replying to netweb:
You have to be logged in…

Right, confirmed :)

That said though, is that the expected behaviour?

As you can tell the behaviour I expected was that regardless of logged in status you should see any and all Trac contributor labels and not just "core contributor" labels like Core Commiter etc

I think we should show these labels regardless of logged in status, anyone else for, or against this?

#8 in reply to: ↑ 7 @SergeyBiryukov
4 years ago

Replying to netweb:

I think we should show these labels regardless of logged in status, anyone else for, or against this?

Agreed.

#9 @knutsp
4 years ago

  1. Thanks for making Trac much better, @nacin
  2. I see no problems with some information only visible to logged in users. Only when logged in you are able to modify, or comment on, tickets. Some information is only really needed when you want to communicate.

#10 @nacin
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

You're welcome, @knutsp. Group effort!

This is built into the XHR that happens to populate the "Notifications" box. While it would be pretty simple to make it so that XHR fires for anonymous users too, I am not sure if it's worth it. Someone tell me if they feel strongly.

Note: See TracTickets for help on using tickets.