WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 3 years ago

#1236 closed defect (fixed)

Issues with adding speakers badge

Reported by: dziudek Owned by: iandunn
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords:
Cc:

Description

Hello,

After WordCamp Poland I've discovered some issues with adding speakers badges to the speakers profiles.

I'm unable to add speakers badge for the following peoples:

  • davoraltman
  • kel-dc

Additonally it is strange that kel-dc were speaker at WordCamp SF (it is mentioned in her activity) but there is no badge in her profile.

Change History (7)

#2 @iandunn
4 years ago

This one is caused by the username vs nicename issue, so it's probably good to have a separate ticket for it.

#3 @Otto42
4 years ago

Those person's actual usernames are "davor.altman" (note the period in the middle) and "Kel DC" (note the capitalization and the space).

Right now, I believe the code expects usernames, not nicenames. That could be changed, but in the meantime, the username can be seen on their forum profile pages:

https://wordpress.org/support/profile/davoraltman
https://wordpress.org/support/profile/kel-dc

The name given to the right of their gravatar picture, in that header space, is their actual username.

#4 @dziudek
4 years ago

@Otto42 - I've found a solution:

When I've set the wp.org username in the speaker profile then the bagde don't appear.

But:

1) I have removed the username
2) Then I have saved the speakers profile
3) And then I have set the wp.org username instead of nicename - after saving it helped (but also replaced the username to nicename automatically)

So in fact it is a strange behaviour with workaround - it is not intuitive.
Please decide if this ticket should be still opened.

For me the issue is solved.

#5 @iandunn
4 years ago

  • Owner set to iandunn
  • Status changed from new to accepted

It's a valid bug report, yeah.

This ticket was mentioned in Slack in #meta by sam. View the logs.


3 years ago

#7 @iandunn
3 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

I think this issue was resolved in r2743.

Note: See TracTickets for help on using tickets.