WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 2 years ago

#1306 closed defect (worksforme)

Bizarre sorting while browsing WordPress themes and plugins

Reported by: ericlewis Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description (last modified by ocean90)

Migrated from: https://core.trac.wordpress.org/ticket/23335

Currently, there's some fuzzy logic while sorting plugins and themes. Sorting by popularity seems to be reset I'm guessing on every major WP version update, which I guess is fair, in which case the problem is just missing the proper description of the sort option.

However, while sorting by rating, nothing really makes sense of the bizarre sort order there. ( Top Rated Themes )

Even while searching for a keyword, and sorting by "rating," the bizarre sorting ensues.

WordPress.org should be a shining example of what WordPress can do, and nail it.

Change History (5)

#1 @netweb
4 years ago

  • Description modified (diff)
  • Reporter changed from chriscct7 to ericlewis

Restored original ticket formatting for improved readability.

#2 @SergeyBiryukov
4 years ago

  • Keywords needs-patch removed

Removing 'needs-patch' from components that are not open sourced yet, to help focus on tickets that actually need a patch.

This ticket was mentioned in Slack in #meta by sam. View the logs.


4 years ago

#4 @ocean90
4 years ago

  • Description modified (diff)

#5 @tellyworth
2 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I think we can count this as fixed along the way as part of search improvements.

Note: See TracTickets for help on using tickets.