Making WordPress.org

Opened 11 years ago

Closed 10 years ago

#131 closed enhancement (wontfix)

Require plugins in directory to use WordPress Media Manager for image management

Reported by: shelob9's profile shelob9 Owned by:
Milestone: Priority: low
Component: Plugin Directory Keywords:
Cc:

Description

I would like to propose that plugins in the theme directory be required to use the Media Manger for all image management. Plugins that use non-standard image management systems due not integrate well with other plugins and can create user lock-in as they make it difficult for users to switch plugins without loosing access to their images. There are many examples of plugins that do this, one that comes to mind is NextGen Gallery.

Change History (5)

#1 @SergeyBiryukov
11 years ago

  • Component changed from General to Plugins Directory

#2 @SergeyBiryukov
11 years ago

  • Summary changed from Require plugins in directory to use WordPress Media Manager for image managment to Require plugins in directory to use WordPress Media Manager for image management
  • Type changed from defect to enhancement

#3 @samuelsidler
11 years ago

I'm not sure I agree. Why should we stop a plugin from doing a better job at image management? I'm not saying that the plugin you mentioned (or others) actually does a better job, but excluding GPL plugins from the directory because they use another image management system seems wrong.

Lock-in sucks, but I'm not sure this is the right answer to that problem.

#4 @bpetty
10 years ago

Yeah, this really isn't a valid reason for denying a plugin or theme from being listed on WordPress.org.

#5 @SergeyBiryukov
10 years ago

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.