WordPress.org

Making WordPress.org

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#1378 closed defect (fixed)

Confusing wording when creating new ticket in WordPress Trac

Reported by: pdfernhout Owned by: nacin
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

The wording on the [new ticket page for WordPress on Trac says two confusing things which could be clarified.

The first confusing thing is that page says: "This form is for reporting bugs in WordPress Trac." [my emphasis]

That could be read confusingly as: "This form is for reporting bugs in the Trac system currently used by WordPress.org".

It might be better if it just said: "This form is for reporting bugs in WordPress."

Or alternatively it could say: "This form is for using the Trac issue reporting system to report bugs in WordPress or to suggest enhancements or make feature requests for WordPress."

The second confusing thing is that for anyone a bit confused after reading the first sentence, the next line reads: "Are you using either the latest version of WordPress Trac, or the latest development version? If not, please update first." [my emphasis]

The key phrase again is "WordPress Trac".

When I read that, it seemed to confirm that indeed the new ticket page I was on was about reporting bug in Trac (as used by WordPress.org), and so I was in the wrong place to report a bug or enhancement in WordPress itself. Why else would I need to update to the latest version of Trac before reporting a bug, given I was already using the Trac web application right then as hosted on WordPress.org? :-)

So, I'd suggest that line should also have the word "Trac" removed from it to read: "Are you using either the latest version of WordPress, or the latest development version? If not, please update first."

The last sentence probably could be further improved to clarify what was meant by "version" versus "development version", as in something like: "Are you using either the latest release version of WordPress, or the latest development version? If not, please update first." [my emphasis on the added word, where emphasis would not be needed in the actual text.]

Change History (4)

#1 in reply to: ↑ description @dd32
17 months ago

Both of these were caused by replacing the static strings with the Trac Project Name in r1997 (It applies to BuddyPress/bbPress too)

cc @nacin

This ticket was mentioned in Slack in #meta-tracdev by dd32. View the logs.


17 months ago

#3 @nacin
17 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 2039:

Trac: Fix project name used when creating a new ticket.

fixes #1378.

#4 @pdfernhout
17 months ago

@nacin Thanks; that was fast! :-)

Note: See TracTickets for help on using tickets.