WordPress.org

Making WordPress.org

Opened 7 years ago

Closed 3 months ago

#145 closed defect (fixed)

Extend Theme previews doesn't stay on same theme when using IE10 or IE9 in Windows 8

Reported by: lancewillett Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description (last modified by SergeyBiryukov)

Migrating from #wp22450:

Originally reported in the forums: http://wordpress.org/support/topic/theme-twenty-twelve-single-post-preview-in-ie10

Extend Theme previews doesn't stay on same theme when using IE10 or IE9 in Windows 8, after clicking from index to a single post view.

What I expected to happen:
To continue previewing the same theme when I click around in the preview.

What actually happened:
The theme changes to Twenty Eleven after clicking

To repeat:

  1. Open http://wordpress.org/extend/themes/twentytwelve
  2. Click green Preview button
  3. Once in the preview, click into a single post
  4. See the theme change to Twenty Eleven

Notes:

  • Breaks in both IE9 and IE10 with Windows 8; does not happen in other browsers like Chrome or Firefox; works fine in IE9 in Windows 7.
  • Happens with any theme on Extend (tested with Twenty Twelve and Esquire)
  • Example URL: http://wp-themes.com/twentytwelve?TB_iframe=true&width=1033&height=612
  • Loading wp-themes.com directly (not in the lightbox) works as expected

Change History (8)

#1 @SergeyBiryukov
7 years ago

  • Description modified (diff)

#2 @celloexpressions
6 years ago

Confirmed with IE11 also. For me, it always changes to Twenty Fourteen, which is presumably the default.

#3 @Otto42
6 years ago

Theory: Something about that version of IE on that setup doesn't allow the iframe to set the cookie telling the site what theme you're supposed to be looking at.

#5 @obenland
2 years ago

Is this still an issue? The theme directory has been redone since this ticket was opened, any chance it got fixed with that?

This ticket was mentioned in Slack in #themereview by dingo_d. View the logs.


4 months ago

#7 @dingo_d
4 months ago

We didn't find issues on IE11 on Windows 10, and we are kinda veering users off of using these browsers anyhow (IE9 is deprecated by MS).

Can we close this @Otto42 ?

#8 @dd32
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

I'm going to assume this is either fixed, or is fixed via #395.

Note: See TracTickets for help on using tickets.