WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1476 closed enhancement (maybelater)

Images are not centralized or are breaking the layout

Reported by: MatheusFD Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

When you upload an image in a ticket, this image get a permalink, like this https://meta.trac.wordpress.org/attachment/ticket/564/banner-1544x500-no-gender.png and https://meta.trac.wordpress.org/attachment/ticket/564/banner-772x250-no-gender.png

The problem is: when it's a big image, it's breaking the layout and when it's a small image, it's aligned to the left. I think that the best thing here is put it in the center.

To understand better, I'll upload some images too

Attachments (4)

image-breaking-screen-size.jpg (35.1 KB) - added by MatheusFD 2 years ago.
image-not-in-the-center.jpg (34.5 KB) - added by MatheusFD 2 years ago.
1476.patch (577 bytes) - added by MatheusFD 2 years ago.
1476.2.patch (554 bytes) - added by MatheusFD 2 years ago.

Download all attachments as: .zip

Change History (16)

@MatheusFD
2 years ago

#1 @Otto42
2 years ago

I kind of disagree with this. It's an attachment. It's supposed to show the actual attachment, not a resized version of it. And centering it doesn't help with understanding things like the width of the image.

Since the attachment displays resized properly in the ticket itself, then I kind of don't care what the attachment page looks like, insofar as I want to see the details of that attachment as it actually is, not some presentation changed version of it.

https://meta.trac.wordpress.org/ticket/564

#2 @MatheusFD
2 years ago

The problem is when it breaks the layout, I think. I think it makes the page a little bit ugly :/

#3 @Otto42
2 years ago

I agree that it makes the page ugly, but you don't look at the direct attachment page for pretty. You look at it to get the file or to understand the problem the attachment is solving or something else. Making things prettier at the expense of having actual information to work with immediately visible to you isn't the best way forward either.

-1 to centering, because this hides valuable information (width)

+0 on scaling down large images, leaning towards against.

Last edited 2 years ago by Otto42 (previous) (diff)

#4 @MatheusFD
2 years ago

What do you think? In let the page in this way?

#5 @MatheusFD
2 years ago

about centering images, if you look, it's a small image, that don't cover all the area. I'm not changing its width :/

#6 @Otto42
2 years ago

No, you're not changing the width, but by centering it, you make it not start at the left hand side anymore, so the width of the image is not immediately visible and comparable to other images on similar pages.

I can't compare different images in different tabs easily because their left-side starting points could now be different. They're located at different places on the page.

#7 @MatheusFD
2 years ago

Oh, ok! I disagree, because I think layout not breaking is very important. If you click any page to compare, the minimum I wait is everything in the right place. If you enter in the page and it's with a broken image, how will you compare? But ok :/

#8 @SergeyBiryukov
2 years ago

I tend to agree with max-width: 100%, but disagree with text-align: center, for the same reason as in comment:6.

#9 @MatheusFD
2 years ago

@SergeyBiryukov ok! So, in the second patch, it's correct! Thanks for the usability class you two (@Otto42) hahaha

@MatheusFD
2 years ago

#10 @SergeyBiryukov
2 years ago

On second thought, looks like Trac doesn't have a link to view images in full size without downloading, so the way it works now is the only way to get an accurate preview for large attachments, even if the page doesn't look pretty.

#11 @MatheusFD
2 years ago

  • Keywords close added; needs-patch 2nd-opinion removed
  • Resolution set to maybelater
  • Status changed from new to closed

ok. So let's maintain the page the way it is. Thanks for the reports!

#12 @Otto42
2 years ago

  • Keywords close removed
Note: See TracTickets for help on using tickets.