Making WordPress.org

Opened 8 years ago

Closed 3 weeks ago

#1496 closed defect (bug) (fixed)

Plugin Search: Search by translated plugin name

Reported by: sergeybiryukov's profile SergeyBiryukov Owned by:
Milestone: Improved Search Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description (last modified by SergeyBiryukov)

I've translated my Allow Cyrillic Usernames plugin's title into Russian. So far so good.

However, when I search by the translated plugin name in the directory, there's only one unrelated match (Pro Related Post Widget).

This would be confusing and unexpected for users. It raises the question of whether translating or transliterating plugin names is a good idea. I think it might be, as long as users can find the plugin by a translated name.

Attachments (3)

meta-1496.png (84.2 KB) - added by SergeyBiryukov 8 years ago.
meta-1496-2.png (123.4 KB) - added by Ipstenu 7 years ago.
classic_editor.png (102.3 KB) - added by dufresnesteven 4 years ago.
@felipeelia. Can you double check your results? It appears to be working for me.

Download all attachments as: .zip

Change History (50)

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


8 years ago

#2 follow-up: @samuelsidler
8 years ago

So... this should be working in the new directory, but doesn't appear to be. You can play around here.

#3 in reply to: ↑ 2 @SergeyBiryukov
8 years ago

Replying to samuelsidler:

You can play around here.

I can't even find the plugin by the original name there :-/ See meta-1496.png.

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


8 years ago

@Ipstenu
7 years ago

#5 follow-up: @Ipstenu
7 years ago

This seems to be working now @SergeyBiryukov ?

#6 in reply to: ↑ 5 ; follow-up: @SergeyBiryukov
7 years ago

Replying to Ipstenu:

This seems to be working now @SergeyBiryukov ?

comment:3 appears to be fixed, but the initial issue of searching by a translated plugin name is still relevant.

#8 in reply to: ↑ 6 @SergeyBiryukov
7 years ago

Replying to SergeyBiryukov:

comment:3 appears to be fixed

Hmm, search only works in the English directory at the moment, probably because of #2425:

#9 @SergeyBiryukov
7 years ago

Searching by the original name appears to works as expected now in both English and Russian directory.

Searching by the translated name only works in Russian directory:

Given that the English directory only displays the original name, I think that's fine (although it would be great to have a consistent search behaviour on English and local directories).

However, searching by the translated name from WP admin with Russian locale still doesn't work: "No plugins match your request".

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#10 @Ipstenu
7 years ago

  • Summary changed from Search by translated plugin name to Plugin Search: Search by translated plugin name

#11 @ocean90
7 years ago

#2812 was marked as a duplicate.

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


7 years ago

#13 @yoavf
7 years ago

One more example:

Searching for transliterated Woocommerce "ووكومرس" on https://ar.wordpress.org/plugins/search doesn't return "WooComerce" but another plugin that has "ووكومرس" in its tags.

#14 @gibrown
7 years ago

Thanks @yoavf

It looks like the problem here is that there are no translations for WooCommerce coming through Jetpack onto WP.com.

I'm not sure why. I know these were working at one point and I thought this ticket had even been closed.

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


7 years ago

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


6 years ago

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


6 years ago

#19 in reply to: ↑ 17 @SergeyBiryukov
6 years ago

Replying to tellyworth:

This looks to be vastly improved as of [6198].

#20 @felipeelia
5 years ago

Hi folks. Just passing here to contribute with two examples of plugins with translated names in pt_BR. These can help because we also use the Latin Alphabet and maybe it makes the tests easier.

  1. We've translated the "Classic Editor" plugin as "Editor clássico". When we search for "Editor clássico" in the pt_BR directory, the plugin isn't found:

https://br.wordpress.org/plugins/search/Editor+cl%C3%A1ssico/
but it's the first result when we search for "Classic Editor":
https://br.wordpress.org/plugins/search/Classic+Editor/

  1. As "Editor Clássico" contains that "a-acute" (á), we could imagine that is the problem. But there is a plugin called "Related" that is translated as "Relacionado". Searching for "Related" it's the 11th result:

https://br.wordpress.org/plugins/search/related/
Searching for "Relacionado" it doesn't even appear in the results:
https://br.wordpress.org/plugins/search/relacionado/

I hope it helps you, folks, to get this figured out. It's very problematic especially for cases like the Classic Editor, where the user reads the plugin name on a Panel notice, for example, but can't find it while searching for it in the Dashboard.

This ticket was mentioned in Slack in #meta-i18n by felipeelia. View the logs.


5 years ago

@dufresnesteven
4 years ago

@felipeelia. Can you double check your results? It appears to be working for me.

#23 @felipeelia
4 years ago

Hi @dufresnesteven,

Yeah, I'm happy to say it is working fine now :) It is worth mentioning that it still does not work on the WP Dashboard though. Thanks!

This ticket was mentioned in Slack in #meta by dd32. View the logs.


4 years ago

#25 @dd32
4 years ago

In 10352:

Plugin Directory: Ensure that all locale translated text gets synced to postmeta so as to get synced to Jetpack ElasticSearch.

See #1496.

This ticket was mentioned in Slack in #meta by kinging. View the logs.


3 years ago

#27 @kinging
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This issue still doesn't seem to be resolved...

My plugin, Ivrita is translated to Hebrew as עבריתה, but doesn't show up when searching for it's Hebrew name in he.wordpress.org. It does show up with the Hebrew name when searching by its English name: https://he.wordpress.org/plugins/search/Ivrita/

I can see other plugins which can be searched for by their localized names, is there anything I need to do in order to index my plugin's localized name as well?

#28 @kinging
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#29 @dd32
3 years ago

In 10506:

Plugin Directory: sync_all_translations_to_meta() can't accept a Post ID, only a WP_Post object or plugin slug.

See [10352].
See #1496.

#30 follow-up: @dd32
3 years ago

Thanks for the report @kinging It looks like your plugin is now showing up in a translated search: https://he.wordpress.org/plugins/search/%D7%A2%D7%91%D7%A8%D7%99%D7%AA%D7%94/

#31 in reply to: ↑ 30 ; follow-up: @kinging
3 years ago

Replying to dd32:

Thanks for the report @kinging It looks like your plugin is now showing up in a translated search: https://he.wordpress.org/plugins/search/%D7%A2%D7%91%D7%A8%D7%99%D7%AA%D7%94/

Thanks for the reply. To be honest, I gave up on fixing it so I ended up adding the translated name as a tag in the readme.txt file, which I heard should work (and it does). But up until that moment when I pushed the new readme file, it didn't show up in the searches.

#32 in reply to: ↑ 31 ; follow-up: @dd32
3 years ago

Replying to kinging:

Replying to dd32:

Thanks for the report @kinging It looks like your plugin is now showing up in a translated search: https://he.wordpress.org/plugins/search/%D7%A2%D7%91%D7%A8%D7%99%D7%AA%D7%94/

Thanks for the reply. To be honest,

Interesting work around! FWIW it wasn't showing up previous to my above commit if I recall correctly, after fixing that I watched the translated title get ingested into the search engine, and then start returning in results..

I've disabled tags for searching purposes momentarily, and your plugin still continued to get matched, so the translations are now being respected. It was simply that the translations weren't being indexed properly.

#33 in reply to: ↑ 32 @dd32
3 years ago

Replying to dd32:

I've disabled tags for searching purposes momentarily, and your plugin still continued to get matched, so the translations are now being respected. It was simply that the translations weren't being indexed properly.

I'll clarify that though, I can still see some ways it's not working as intended, text that is in the description of the plugin that should be matching doesn't appear to (but looks like it should be in the index, although i haven't checked directly), so I'll have to look further into that (potentially checking another locale to determine if it's specific to hebrew or translations)

#34 @kinging
3 years ago

Thank you for your work on this issue! Perhaps your commit and my tag addition happened at the same time :D

If there's anything I can do to help figure this out, e.g. add translations for another locale - let me know.
(Although I'm not the PTE for other locales so it would require someone to approve them)

#35 @gibrown
3 years ago

  • Milestone set to Improved Search

This ticket was mentioned in Slack in #polyglots by yui. View the logs.


3 years ago

#37 @SergeyBiryukov
3 years ago

  • Description modified (diff)

This ticket was mentioned in Slack in #polyglots by yui. View the logs.


2 years ago

This ticket was mentioned in Slack in #polyglots by vladytimy. View the logs.


2 years ago

#40 @efedinler
2 years ago

Hi guys!

We also have the same issue with our plugin https://wordpress.org/plugins/backup-backup and noticed that for some languages e.g. Vietnamese and Greek, the translations are indexed (those keywords are in the plugin’s readme file) please see:

https://vi.wordpress.org/plugins/search/T%E1%BA%A1o+b%E1%BA%A3n+sao/
https://el.wordpress.org/plugins/search/%CE%B4%CE%B7%CE%BC%CE%B9%CE%BF%CF%85%CF%81%CE%B3%CE%AF%CE%B1+%CE%B1%CE%BD%CF%84%CE%B9%CE%B3%CF%81%CE%AC%CF%86%CF%89%CE%BD/

However it is still an issue for the majority of the other languages for example Brazilian Portuguese https://br.wordpress.org/plugins/search/Criar+backup/. The keywords “Criar” and “Backup” are present in the translated readme at https://br.wordpress.org/plugins/backup-backup/ and the search in the Brazilian Portuguese directory isn’t returning any results.

We thought it’s a good idea to contribute with the finding that it works correctly for Vietnamese and Greek (not only for our plugin but works fine for others too) and doesn’t work still for other languages. Maybe it helps with debugging.

If anyone found a solution for this, your input would be greatly appreciated.

#41 @robfelty
2 years ago

Thanks for the update on this. I looked into it, and we do have the content indexed for these languages. I think the issue lies somewhere in the querying code, which I cannot easily test myself. I tried this Elasticsearch query and was able to find the plugin. Could you take a look at the query code @dd32

{
  "query": {
    "bool": {"must": [
      {"match_phrase": {
        "content_pt_BR": "criar backup"
      }}
    ]}
  }
}

#42 @dd32
2 years ago

In 11649:

Plugin Directory: Search: Some code formatting cleanup, documenting of variable values, disabling debug logging.

See #1496.

#43 @dd32
2 years ago

In 11650:

Plugin Directory: Search: Use the full locale for localised searches, eg, pt_BR rather than pt.

Previously we have used 'short' locales for some searching, but all current plugins in the search index are keyed using the full locale, causing localised searches to now fail to match against the translated texts.

See #1496.

This ticket was mentioned in Slack in #polyglots by yui. View the logs.


23 months ago

#45 follow-up: @dd32
19 months ago

As far as I can tell, the only thing that doesn't currently work, is searching for a translated plugin name in the context of a different locale

For example, searching for a Russian transliterated plugin name in the English directory, or searching for a plugin in the context of the fr_FR locale with a german phrase.

I think this ticket can be marked as fixed?

#46 @dd32
19 months ago

#6088 was marked as a duplicate.

#47 in reply to: ↑ 45 @dd32
3 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to dd32:

As far as I can tell, the only thing that doesn't currently work, is searching for a translated plugin name in the context of a different locale

For example, searching for a Russian transliterated plugin name in the English directory, or searching for a plugin in the context of the fr_FR locale with a german phrase.

I'm closing this ticket as fixed, the above is filed in a new enhancement: #7617

Note: See TracTickets for help on using tickets.