WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1521 closed defect (fixed)

Tabbing through a Trac ticket before submitting a comment results in it being closed with no resolution

Reported by: johnbillion Owned by: ocean90
Milestone: Priority: normal
Component: Trac Keywords: has-patch commit
Cc:

Description

I thought there was a ticket for this already, but I couldn't find it.

Tabbing through the form inputs on a Trac ticket results in the focus passing through the action_dupe text input. When this input gets focus, the "mark as duplicate of #" radio button gets automatically checked. When the form is submitted, the ticket gets closed but without a resolution because no duplicate ticket number is entered.

This means it's impossible to use the keyboard only to submit a comment on Trac without closing it.

Note that @arush just experienced this on #WP35479.

Attachments (1)

meta-1521.patch (1.3 KB) - added by SergeyBiryukov 4 years ago.

Download all attachments as: .zip

Change History (4)

#1 @johnbillion
4 years ago

Actually, it's not impossible to leave a comment without closing it, but it's difficult.

#2 @SergeyBiryukov
4 years ago

  • Keywords has-patch commit added; needs-patch removed

Trac has some JS code to handle this, but it's overridden by some of our own code.

meta-1521.patch fixes this by hiding action text inputs from keyboard, unless the corresponding action is focused. It also allows for select inputs to be clicked directly as well (in addition to text inputs).

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

#3 @ocean90
4 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 2310:

Trac: Don't make action text inputs and select fields focusable until the corresponding action is focused.

Also allow action select fields to be clicked directly.

Props SergeyBiryukov.
Fixes #1521.

Note: See TracTickets for help on using tickets.