WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#1650 closed defect (fixed)

User getting a "Sorry, post is too old" error when editing a plugin review

Reported by: SergeyBiryukov Owned by: Otto42
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

I got a report of someone not being able to edit their plugin review or change the rating after the issue has been resolved. The review is for MyPress plugin. I've sent the user to the review form, but they're getting a "Sorry, post is too old" error.

Per otto42's replies on a related topic, reviews are not subject to regular post editing age restrictions and should be editable at any time, so it appears to be a bug.

Change History (4)

#1 follow-up: @Otto42
3 years ago

  • Owner set to Otto42
  • Status changed from new to accepted

I can't reproduce this. Using test accounts and changing the times, I can edit reviews forever. Need something I can see. Happy to steal somebody's account if they can make it happen for me. Have them email me.

#2 in reply to: ↑ 1 @SergeyBiryukov
3 years ago

Replying to Otto42:

I can't reproduce this. Using test accounts and changing the times, I can edit reviews forever.

If it helps, here's the review in question: https://wordpress.org/support/topic/does-not-work-605

#3 @Otto42
3 years ago

That helps a lot.

Looks like it's an issue with the first-post-cache and how it works when posts get deleted. The review-to-be-edited that was showing up for that particular user/plugin was actually showing the deleted reply by the author, not the review by the user. The review system will need to be changed to avoid using bb_get_first_post there, most likely.

Anyway, undeleting that post reset the post-positions and the cache, so that user can now edit their review with no issues.

#4 @SergeyBiryukov
3 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.