WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 5 months ago

#1652 closed defect (worksforme)

Inconsistent GUIDs on RSS feeds served over HTTP vs HTTPS

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Component: SSL Keywords:
Cc:

Description

Originally reported via the maintainer of the Feedbin RSS reader back in 2014 and subsequently fixed, but the issue has re-appeared.

The GUIDs of items in RSS feeds on WordPress.org and WordPress.com appear to be affected by the current scheme, as opposed to using the canonical scheme. This only causes a problem due to persistent caching on .org/.com which causes an HTTP GUID to be served to an HTTPS feed, and vice versa, depending on the luck of the draw when it comes to cache population.

Change History (5)

#1 @johnbillion
2 years ago

cc @joelwills

#2 follow-up: @dd32
2 years ago

There shouldn't exist any HTTP-served feeds on WordPress.org at present. The Guids would have unfortunately changed when the HTTP -> HTTPS switch was performed.

Is https://wordpress.org/plugins/rss/browse/new/ the example of a feed that supposedly contains http:// guids? (I'm asking, as I've tried several times bypassing caching and am unable to duplicate)

#3 in reply to: ↑ 2 @johnbillion
2 years ago

Replying to dd32:

Is https://wordpress.org/plugins/rss/browse/new/ the example of a feed that supposedly contains http:// guids?

Correct. I just visited that URL and the item GUIDs in the feed look like this:

<guid isPermaLink="false">97725@http://wordpress.org/plugins/</guid>

#4 @dd32
2 years ago

Thanks, I have tried a few more times, and managed to duplicate it.

Oddly enough, I can only duplicate it if I hit an invalid feed URL, such as https://wordpress.org/plugins/rss/browse/new/blahh, something like https://wordpress.org/plugins/rss/browse/new/?blahh doesn't trigger it (no matter how many times you try).
This could be due to the multiple layers of rss caching playing havoc, but it seems pretty reproducible.

#5 @ocean90
5 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Doesn't seem to be an issue anymore after the bbPress 2.x upgrade and the new plugin directory.

Note: See TracTickets for help on using tickets.