WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#1686 closed defect (fixed)

New Submission Form - Cannot Specify Name

Reported by: Ipstenu Owned by: obenland
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

In looking at the new form, it defaults the name to the value of "plugin name" in your main plugin file.

Drafted language for the submission page:

Your plugin’s URL will be populated based on the value of Plugin Name in your main plugin file. If you set yours as Plugin Name: Boaty McBoatface then your URL will be https://wordpress.org/plugins/boaty-mcboatface and your slug will be boaty-mcboatface for example. If there is an existing plugin with your name, then you will be boaty-mcboatface-2 and so on. It behaves exactly like WordPress post names.

However...

This makes it hard for developers to let us know that maybe they wanted 'halfelf-mcboatface' for the URL while the Plugin Name is 'Boaty McBoatface by the Super Elf, Mika!'

Plus this actually *increases* the probability of what @otto42 refers to as "Poorly thought out names" (only he says it in Otto-ese).

We often get submissions like "Jumpstart Your Jetpack with Booster Gold! He's From the Future!" which would have a really silly URL: jumpstart-your-jetpack-with-booster-gold-he-s-from-the-future

I wanted to write this:

The plugin name you submit here will become the URL of the plugin in the directory (aka your plugin’s slug) and it is not changeable after approval. The plugin name works exactly like the WordPress post title does. If you submit “My Cool Product Name” then your plugin URL will become https://wordpress.org/plugins/my-cool-product-name and your slug will be my-cool-product-name, which may not be what you wanted.

We recommend you leave out small words like ‘the’, ‘and’, ‘with’, etc. You can submit your plugin name as the desired slug (ex booster-pack-gold instead of “Booster Pack for Jetpack – Gold Edition”, which would be booster-pack-for-jetpack--gold-edition) to ensure you get the best slug for your plugin.

Which leads me to ask if there's a way we could have a final check? "Your plugin has passed it's uploader checks and, when approved, your URL will be https://wordpress.org/plugins/boaty-mcboatface" - Is this URL acceptable? [yes/no dropdown]"

And the dropdown, if no, would have a text field for you to rename it.

Attachments (1)

1686-github.png (96.3 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (15)

@ocean90
3 years ago

#1 @ocean90
3 years ago

Live-feedback/validation like GitHub has might be helpful too, see 1686-github.png.

#2 @obenland
3 years ago

Maybe we could add a paragraph to let them know they can change their plugin's name after it has been approved?

#3 @Ipstenu
3 years ago

CAN'T change it after approval. It'll mess up SVN.

And the issue is what if your plugin is perfectly fine, code wise, so I approve it and you wanted to change the name? I was kind of hoping to not have to do the whole "Okay, we'll close this and you can resubmit." dance.

#4 @obenland
3 years ago

Oh, you can't change the name either? Why does SVN care about the name as long as the slug stays the same?

Are plugin authors requesting a different slug for their plugins something that happens quite frequently?

#5 @dd32
3 years ago

You can change the name of the plugin, just can't change it's slug.

I'd really like to see the submission form ask for more than a zip though, with the possibility for reviewers to alter the slug prior to approval (to remove obviously not-acceptable-things).

The slug could be auto-generated from the plugin name, with an optional edit (like the Slug edit in wp-admin)

Plugin Name: [ My Super Awaesome Thinggi! ]
Requested Slug: [ awesome-thing ]
Description: [ Super Awesome thing is a widget that says I'm Awesome ]
Upload Zip / URL:

[Request]

#6 @Ipstenu
3 years ago

I'm talking about the slug, Obenland. The confusion is because we use 'plugin name' in the current form.

Today: People type in a name and it's converted to a post name that cannot be changed. This is called your 'Plugin Name' in the submission form

The proposed form: The postname is extracted from the Plugin Name.

The PROBLEM: If a plugin is approved right away, we cannot change the SLUG.

Ergo: People cannot request a specific slug and will get a URL they don't want.

That breaks SVN. And we cannot accept certain slugs (like google-analytics-by-bob is not okay). If we can edit the post-name after submission but before approval, that helps some things (like Google etc) but not the current problem of "Oh I didn't want the url /boaty-mcboatface/!" Which I'm hoping we can resolve :)

#7 @obenland
3 years ago

Okay, I thought so but wasn't sure if there wasn't a fancy sync script quirk that I wasn't aware of.

Do you think going with the slug-edit in wp-admin would work for now and we could circle back to this after release?

#8 follow-up: @Ipstenu
3 years ago

Slugedit is a good first step :) I beefed up the lingo on the submission page.

A future release would be awesome if we could do Ocean's thing. Scan the plugin, yay it's passed a scan! Your repo slug will be boaty-mcboatface, last chance to edit!

#9 in reply to: ↑ 8 @obenland
3 years ago

Replying to Ipstenu:

A future release would be awesome if we could do Ocean's thing. Scan the plugin, yay it's passed a scan! Your repo slug will be boaty-mcboatface, last chance to edit!

Right, fwiw in my mind we (or at least I) won't stop working on the directory after the switch, but continue to iterate to add some of the bells and whistles that have come up on this Trac. So I don't expect the wait in that to be too long. (famous last words)

This ticket was mentioned in Slack in #meta by obenland. View the logs.


3 years ago

#11 @obenland
3 years ago

  • Milestone changed from Plugin Directory v3 - M1 to Plugin Directory v3 - M3

#12 @samuelsidler
3 years ago

  • Summary changed from New Submission Form - Cannot Speficy Name to New Submission Form - Cannot Specify Name

#13 @obenland
3 years ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 3091:

Plugin Directory: Allow Plugin Admins to edit slugs.

Let's Admins change plugin slugs as long as they've not been approved yet.

Fixes #1686.

#14 @samuelsidler
2 years ago

  • Milestone Plugin Directory v3 - M3 deleted

Milestone Plugin Directory v3 - M3 deleted

Note: See TracTickets for help on using tickets.