WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#1698 closed defect (fixed)

PHP errors in developers reference site.

Reported by: Nikschavan Owned by: coffee2code
Milestone: Priority: normal
Component: Developer Hub Keywords: needs-patch close
Cc:

Description

Just after provisioning the WordPress meta environment these errors are seen on the http://developer.wordpressorg.dev/reference/ site.

http://screenshots.sharkz.in/nik/2016/05/chrome_2016-05-07_12-03-51.png

Change History (2)

#1 @Nikschavan
3 years ago

  • Keywords close added

After looking into the code, it seems that this specifically issues for the meta-environment. The database in this environment does not have the required terms.

<?php
$version = get_terms( 'wp-parser-since', array(
        'number' => '1',
        'order'  => 'DESC',
        'name'   => $current_version,
) );
Last edited 3 years ago by Nikschavan (previous) (diff)

#2 @coffee2code
3 years ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 3315:

developer.wordpress.org: Prevent errors on reference landing page when no wp-parser-since terms are found.

Primarily for development installs of the theme.

Fixes #1698.

Note: See TracTickets for help on using tickets.