WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1736 closed enhancement (duplicate)

Webservice/endpoint to fetch user profile plugins

Reported by: Compute Owned by:
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description

It would be really cool if we could start using the data from wordpress.org more and integrate it into our own websites.

One of these featured I think alot of people really could use was a webservice/endpoint that could return the results of the plugins of a user profile:
https://profiles.wordpress.org/peytzco#content-plugins

Change History (5)

#1 @ocean90
3 years ago

  • Component changed from General to Profiles
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #613.

#2 @dd32
3 years ago

FWIW, the contents of the plugin tab is accessible through the plugins api.

For example: https://api.wordpress.org/plugins/info/1.1/?action=query_plugins&request[author]=peytzco&request[fields][active_installs]=1

#3 follow-up: @Compute
3 years ago

@ocean90 Thanks for the update. I will watch that ticket instead
@dd32 Thanks for the example. But it seems like I'm getting alot more plugin than the one this user is an author on.

info: {
  page: 1,
  pages: 1869,
  results: 44833
}

#4 in reply to: ↑ 3 @dd32
3 years ago

Replying to Compute:

@dd32 Thanks for the example. But it seems like I'm getting alot more plugin than the one this user is an author on.

Refresh, turned out I hadn't pushed that change live.. oops.

#5 @Compute
3 years ago

Thank you! Looks alot better now :D

Note: See TracTickets for help on using tickets.