WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 3 years ago

#177 closed enhancement (duplicate)

Add cross referencing throughout code reference

Reported by: samuelsidler Owned by:
Milestone: Priority: normal
Component: Developer Hub Keywords:
Cc:

Description

The code reference should cross reference itself. e.g., hooks that appear inside of a function, or functions attached to hooks.

Change History (9)

#1 @samuelsidler
4 years ago

  • Priority changed from low to normal

#2 @siobhan
4 years ago

  • Cc siobhan added

#3 follow-ups: @toscho
4 years ago

  • Cc toscho added

One simple way to find related related posts would be the Trac ticket number. In some docs, this number is available, so we could store its value in a post meta field. Unfortunately, there seems to be no standard. I found four different variants in wp-includes/functions.php:

// see http://core.trac.wordpress.org/ticket/9396

<!DOCTYPE html>
<!-- Ticket #11289, IE bug fix: /* snip */
-->

 * See http://core.trac.wordpress.org/ticket/8497

 * @link http://core.trac.wordpress.org/ticket/19589

It would be nice to have a standard. We could extend the PHP doc standard with a new tag and a vendor prefix:

 * @wp-ticket http://core.trac.wordpress.org/ticket/19589

Not sure what the best place is to discuss that topic. Make? Core trac? Chat? This trac?

#4 in reply to: ↑ 3 @samuelsidler
4 years ago

Replying to toscho:

Not sure what the best place is to discuss that topic. Make? Core trac? Chat? This trac?

Bring it up with the inline docs team and see what they think. Best way to do that is attend their weekly meeting or comment on their weekly update on make.

#5 in reply to: ↑ 3 @kpdesign
4 years ago

Replying to toscho:

It would be nice to have a standard. We could extend the PHP doc standard with a new tag and a vendor prefix:

 * @wp-ticket http://core.trac.wordpress.org/ticket/19589

Not sure what the best place is to discuss that topic. Make? Core trac? Chat? This trac?

All links to Trac tickets and other external documentation will be handled using the @link tag in the doc blocks. References to other functions/classes/hooks/etc. will be done using the @see tag.

We are trying to stay away from using any custom tags in the doc blocks.

We're aware of the inconsistencies, and are working hard to fix them.

You, and anyone else, are always welcome to attend our weekly inline docs chat, Wednesdays at 18:00 UTC in #wordpress-sfd, or reach out to @DrewAPicture or myself with questions in between meetings. :)

#6 @trishasalas
4 years ago

  • Cc trisha@… added

#7 @RMarks
3 years ago

  • Cc rmarks@… added

This ticket was mentioned in Slack in #meta-devhub by siobhan. View the logs.


3 years ago

#9 @siobhan
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #323.

Note: See TracTickets for help on using tickets.