WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#1808 closed defect (fixed)

Jetpack isn't automatically connected on Rosetta o2s

Reported by: pento Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

Change History (6)

#1 @ocean90
3 years ago

FYI: The connection for base sites is currently a manual task when creating a new site.

We can probably reuse the code which WordCamp.org is using: https://meta.trac.wordpress.org/browser/sites/trunk/wordcamp.org/public_html/wp-content/mu-plugins/jetpack-tweaks/new-sites.php

#2 @pento
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in dotorg:r12247.

#3 follow-up: @ocean90
3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

There was a typo in the function name, see [dotorg12371]. Even with this fix the site it.wordpress.org/team wasn't connected. Re-opening for investigation.

#4 in reply to: ↑ 3 @ocean90
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to ocean90:

Even with this fix the site it.wordpress.org/team wasn't connected.

This was caused by using the wrong URL:

Error Details: The Jetpack server was unable to communicate with your site https://it.global.wordpress.org [IXR -32300: transport error: http_request_failed SSL: no alternative certificate subject name matches target host name 'it.global.wordpress.org'

Fix deployed in [dotorg12373] which changes the priority of the action which rewrites the URLs.

#5 @ocean90
3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Looks like there is still an issue.

During wpmu_new_blog action:

1472905760: Connecting new site 450.
1472905761: Could not connect site 450: Error Details: The Jetpack server encountered the following client error: Verification took too long
1472905762: Connecting new site 450 complete.

Calling rosetta_auto_connect_new_site_to_jetpack() directly:

1472905850: Connecting new site 450.
1472905853: Connecting new site 450 complete.

#6 @ocean90
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [dotorg12379] rosetta_auto_connect_new_site_to_jetpack() was moved into a scheduled event. Tested with nl.wordpress.org/team and ro.wordpress.org/team.

Note: See TracTickets for help on using tickets.