WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 22 months ago

#1824 closed task (fixed)

Improve "Contributors & Developers" box

Reported by: samuelsidler Owned by:
Milestone: Priority: low
Component: Plugin Directory Keywords:
Cc:

Description

There's a few things we can do to improve the "Contributors & Developers" box:

  • Show some text before showing the list of contributors. For example: [plugin name] is open source software. The following people have contributed to this plugin.
  • In the contributors list, if a name is very long, it wraps into a new line. Unfortunately, it wraps under the gravatar. (This is more rare with the smaller font size.)
  • The contributors list should be sorted by case-insensitive username. At the moment, capitalized usernames are sorted first (see Jetpack).
  • After the list of contributors, list all languages the plugin is available in, with links to relevant Rosetta sites. We should do this with a sentence as well, such as: [plugin name] has been translated into these [number] locales: [locale list with links].
  • Then, follow up with: Thank you to <a>the translators</a> for their contributions. <a>Translate [plugin name] into your language.</a>
  • Add more text to the bottom of the section, instead of a list of items. I'd title it "Interested in development?" in bold, with the following text: <a>Browse the code</a> or subscribe to the <a>development log</a> by <a>email</a> or <a>RSS</a>. That should cover all links except translation contributors, which is covered above.

We can probably improve the language a bit, but that's the general idea.

Change History (21)

#1 @DeFries
3 years ago

Could this include to a "Contribute" button/link that links to an optional version control repository?

#2 follow-up: @petya
3 years ago

A couple of questions:

  • Will the list of translations include only 100% completed translations?
  • Another question also dependent on the answer of the first one - why link to Rosetta sites instead of the plugin translation projects where people can get involved directly?
  • Are translators going to be listed per locale or all in one place? Wouldn't listing all contributors and all translators that way make the page impossibly long? Are you planning on listing all contributing translators or just GTEs and Project translation editors?
  • Doesn't it make sense to try and add the links to translations in a more visible place (above/below support in the right column for example) with a list of existing translations and a call to action to Translate? With the current plan, as far as I understand, the call to action to translate this plugin will go below the list of contributors, then the list of translations and translators, at the very bottom of the page which is not ideal.
Last edited 3 years ago by petya (previous) (diff)

#3 in reply to: ↑ 2 @samuelsidler
3 years ago

Replying to petya:

  • Will the list of translations include only 100% completed translations?

The list of translations will be any that have a generated language pack. Currently, the threshold for a language pack is 95%.

  • Another question also dependent on the answer of the first one - why link to Rosetta sites instead of the plugin translation projects where people can get involved directly?

I'm not sure which link you're asking about, but I'll both of them:

  • For the note that says [plugin name] has been translated into these [number] locales: [locale list with links]., we link to the localized plugin directory because that's where users are looking to go. If a plugin is translated into Bulgarian and we're telling them it's available, sending them to the Bulgarian page makes the most sense. If we send them to a translation site, they'll be confused as to why since they didn't ask to translate the plugin (and hey, it's already translated).
  • For the <a>Translate [plugin name] into your language.</a> link, it will lead to translate.wordpress.org, since that's the call to action and expected behavior.
  • Are translators going to be listed per locale or all in one place? Wouldn't listing all contributors and all translators that way make the page impossibly long? Are you planning on listing all contributing translators or just GTEs and Project translation editors?

We will link to the relevant translate.wordpress.org page. That is, if you're on bg.wordpress.org/plugins-wp/, we'll link to the Bulgarian translators for that particular plugin. There's no proposal to list all translation contributors on the page at the moment, but rather to link to translate.wordpress.org. (On the English site, we'd want to link to the overview of all contributors to a project.)

  • Doesn't it make sense to try and add the links to translations in a more visible place (above/below support in the right column for example) with a list of existing translations and a call to action to Translate? With the current plan, as far as I understand, the call to action to translate this plugin will go below the list of contributors, then the list of translations and translators, at the very bottom of the page which is not ideal.

There are two call-to-actions:

  1. On each plugin page, a green bar appears if the plugin is available for translation and not translated into the current language.
  2. When listing translation information (in the Contributors & Developers section; i.e. this ticket), we link to the translation site.

Adding the green bar is more visible than putting a Translate button in the sidebar. In fact, the current translate button is very rarely used. We want to make translations more visible so users are more encouraged to get involved.

Listing all languages is also not very useful, as long lists are often ignored. It's more important that users know if the plugin is available in their language. That's why the green bar shows when it's not, and how to get involved. (And on the main site, if it's available in your language, sends you to the relevant Rosetta site.)

#4 @mapk
3 years ago

  • Milestone set to Plugin Directory v3 - M9

#5 @mapk
3 years ago

I've rectified some of these bullets above.

https://meta.trac.wordpress.org/changeset/4313

#6 @netweb
3 years ago

In [4313]

Reference ticket #1824
Added text to beginning of Contributor section.
Float contributor avatar to left so name doesn't wrap under it.
Added text to bottom of list in a paragraph format including links to codebase,etc.
Removed letter-spacing on FAQs.

This ticket was mentioned in Slack in #meta by mapk. View the logs.


3 years ago

#8 @mapk
3 years ago

In 4322:

Plugin Directory: Improve Contributors section & Changelog section.

Added Changelog section sass file.
Removed placement of #changelog selector from image-gallery sass.
Added Developers/Contributors php file.
Ported over some earlier changes on React files to the php files.

See #1824

#9 @tellyworth
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This ticket was mentioned in Slack in #meta-i18n by sergey. View the logs.


3 years ago

This ticket was mentioned in Slack in #meta by sam. View the logs.


3 years ago

#12 @samuelsidler
3 years ago

  • Milestone Plugin Directory v3 - M9 deleted

Milestone Plugin Directory v3 - M9 deleted

#13 @obenland
3 years ago

In 5214:

Plugin Directory: Make intro text more plugin-related

See #1824.

#14 @obenland
3 years ago

In 5218:

Plugin Directory: Update developers section.

Replaces lists with full sentences and adds locale details.

See #1824.
Fixes #2629.

#15 @Ipstenu
3 years ago

Can we restore the SVN link? It's really useful because it's SO much faster than trac (which has to load css and apps and stuff). If you just want to go in and see what you goofed in your readme or what tags have been created, it's a better experience.

#16 @lukecavanagh
3 years ago

Please could you restore the SVN link instead of the plugin trac link, looks like that change was in Changeset 5218.

#17 @Ipstenu
3 years ago

@lukecavanagh - Is there a reason you're repeating what I literally just said a post above you? I understand you're trying to show support for this ticket but (a) that's what the watch stars are for and (b) what you're doing is making it harder for everyone to keep up with the volume of posts going on here. Your enthusiasm is great, but please consider if you're adding something new or not.

#18 follow-up: @lukecavanagh
3 years ago

@Ipstenu

Not there is not, so do not comment, unless what I am saying it unique in some way. One comment is not that much volume.

#19 in reply to: ↑ 18 ; follow-up: @samuelsidler
3 years ago

Replying to lukecavanagh:

Not there is not, so do not comment, unless what I am saying it unique in some way. One comment is not that much volume.

You've been asked repeatedly to not summarize already-clear comments. Please refrain from doing so going forward as it's distracting, adding to the overhead of messages, and prevents people from contributing to and building the plugin directory. If you have questions about when and how you should comment on trac, please find me on Slack (sam).

#20 in reply to: ↑ 19 @lukecavanagh
3 years ago

Sure I will not summarize already-clear comments. I was just trying to agree to something. I did not know there was a standard of how I should comment on trac.
https://make.wordpress.org/meta/handbook/

Replying to samuelsidler:

Replying to lukecavanagh:

Not there is not, so do not comment, unless what I am saying it unique in some way. One comment is not that much volume.

You've been asked repeatedly to not summarize already-clear comments. Please refrain from doing so going forward as it's distracting, adding to the overhead of messages, and prevents people from contributing to and building the plugin directory. If you have questions about when and how you should comment on trac, please find me on Slack (sam).

This ticket was mentioned in Slack in #polyglots by ocean90. View the logs.


22 months ago

Note: See TracTickets for help on using tickets.