WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 23 months ago

#1867 closed defect (fixed)

Some links are broken

Reported by: extendwings Owned by: jmdodd
Milestone: Priority: high
Component: International Forums Keywords:
Cc:

Description

I notice that some links at Japanese forum are broken.
It looks like related to topic title length.

For example,

Change History (7)

#2 follow-up: @tenpura
23 months ago

Is it possible to change the permalink settings to ID based rather than slug ones? I suspect that this is caused by MySQL column length limitation. WP core has the same problem.

See: https://core.trac.wordpress.org/ticket/17771

#4 in reply to: ↑ 2 @SergeyBiryukov
23 months ago

Replying to tenpura:

I suspect that this is caused by MySQL column length limitation. WP core has the same problem.

See: https://core.trac.wordpress.org/ticket/17771

It's worth noting that #wp17771 only affects pingbacks, regular post slugs are truncated correctly since 3.6 (see #wp21013).

#5 follow-up: @SergeyBiryukov
23 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This topic URL works, but cannot be urldecoded correctly due to an extra %d1 at the end, so browsers don't display it in human-readable form in the address bar, like other topics:
https://ru.wordpress.org/support/topic/%d0%94%d0%b2%d1%83%d1%8f%d0%b7%d1%8b%d1%87%d0%bd%d1%8b%d0%b9-%d1%81%d0%b0%d0%b9%d1%82-%d0%b1%d0%b5%d0%b7-%d0%b8%d1%81%d0%bf%d0%be%d0%bb%d1%8c%d0%b7%d0%be%d0%b2%d0%b0%d0%bd%d0%b8%d1%8f-%d0%bc%d0%b0%d1/

Any way to double-check the fixer script?

#6 in reply to: ↑ 5 @jmdodd
23 months ago

  • Owner set to jmdodd
  • Status changed from reopened to assigned

I re-ran the script with an additional set of decode/encode/decode comparisons and it caught this instance but no others:

Updated post ID 216625 from 
%d0%94%d0%b2%d1%83%d1%8f%d0%b7%d1%8b%d1%87%d0%bd%d1%8b%d0%b9-%d1%81%d0%b0%d0%b9%d1%82-%d0%b1%d0%b5%d0%b7-%d0%b8%d1%81%d0%bf%d0%be%d0%bb%d1%8c%d0%b7%d0%be%d0%b2%d0%b0%d0%bd%d0%b8%d1%8f-%d0%bc%d0%b0%d1
to
%d0%94%d0%b2%d1%83%d1%8f%d0%b7%d1%8b%d1%87%d0%bd%d1%8b%d0%b9-%d1%81%d0%b0%d0%b9%d1%82-%d0%b1%d0%b5%d0%b7-%d0%b8%d1%81%d0%bf%d0%be%d0%bb%d1%8c%d0%b7%d0%be%d0%b2%d0%b0%d0%bd%d0%b8%d1%8f-%d0%bc%d0%b0

I'll leave this open until I'm certain that I've fixed the importer.

#7 @jmdodd
23 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.