WordPress.org

Making WordPress.org

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#1878 closed defect (invalid)

Searching for strings shouldn't include file names in the results

Reported by: netweb Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Searching customizer will return results where the filename includes customizer in the filename, e.g. functions/customizer.php:231 even though the translation string does not contain customizer

Here's a search highlighting the issue

https://translate.wordpress.org/projects/wp-themes/traffica/en-au/default?filters%5Bterm%5D=customizer&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&sort%5Bby%5D=original&sort%5Bhow%5D=asc&sorts=Sort

Change History (4)

#1 follow-up: @ocean90
17 months ago

  • Keywords needs-patch removed
  • Resolution set to invalid
  • Status changed from new to closed

It's not a bug, it's a feature of GlotPress. 😉

Last edited 17 months ago by ocean90 (previous) (diff)

#2 in reply to: ↑ 1 ; follow-up: @netweb
17 months ago

Replying to ocean90:

It's not a bug, it's a feature of GlotPress. 😉

How so?

I see it as a regression :( Any chance of adding a filter so that filenames are excluded from search?

#3 in reply to: ↑ 2 ; follow-up: @ocean90
17 months ago

Replying to netweb:

I see it as a regression

A regression?

#4 in reply to: ↑ 3 @netweb
17 months ago

Replying to ocean90:

Replying to netweb:

I see it as a regression

A regression?

Fair enough :)

Note: See TracTickets for help on using tickets.