WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 months ago

#1923 closed defect (reported-upstream)

Forums should have a way to search for posts made from a particular IP address

Reported by: SergeyBiryukov Owned by: netweb
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

After the upgrade to bbPress 2.x, there's no longer a way to quickly view the poster's IP address, or search for all posts made from that IP.

Previously, IP address was displayed in the author info block for each post, with a link to all posts made from that IP.

Currently, IP address is only displayed in a meta box in the admin when editing a post, and there's no way to search for all posts made from that IP.

Change History (7)

#1 @netweb
3 years ago

Related:

  • #bbPress2908 Add template and functions to allow viewing topics and replies by author IP address
Last edited 2 years ago by netweb (previous) (diff)

#2 @netweb
3 years ago

  • Component changed from International Forums to Support Forums

#3 @SergeyBiryukov
2 years ago

Apparently it's not just search by IP that's missing, currently there's no way to search for a particular user's posts at all. Created #2490 for that.

This ticket was mentioned in Slack in #forums by sergey. View the logs.


19 months ago

This ticket was mentioned in Slack in #forums by clorith. View the logs.


13 months ago

#6 @netweb
13 months ago

  • Owner set to netweb
  • Status changed from new to accepted

#7 @dd32
3 months ago

  • Resolution set to reported-upstream
  • Status changed from accepted to closed

I'm going to close this as a duplicate of #bbPress2908 for now.

If the mods find that this is needed urgently enough we can bump the priority and/or re-open it for a WordPress.org-specific implementation.

Note: See TracTickets for help on using tickets.