WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#1929 closed defect (worksforme)

Missing post author name and avatar in email notifications from make blogs

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: close
Cc:

Description

See the screenshot.

Attachments (1)

meta-1929.PNG (29.5 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (13)

#1 @samuelsidler
3 years ago

This happened on a number of sites. Pretty sure it's Jetpack...

#2 @kraftbj
3 years ago

I'm investigating. Sam is likely right it's Jetpack. :)

#3 @kraftbj
3 years ago

I found the issue on Jetpack's end. Two-fold: 1. For Polyglots, we aren't expecting users on the network but not on the subsite to be able to publish. 2. For all sites, we are expecting to have some author information available when it isn't in some contexts.

I've brought it up internally since there's a few different possible approaches to take (internal to WP.com or within the Jetpack code itself) to get some additional eyes for guidance.

This ticket can include any notification e-mail that is lacking author info (like Joe's info on make/core.

#4 follow-up: @netweb
3 years ago

#5 in reply to: ↑ 4 @kraftbj
3 years ago

Replying to netweb:

Just a heads up, a post from #core today is also affected:

Thanks—no need for further reports. The underlying issue is there's a set of circumstances where a Jetpack-powered site can make a post where WP.com isn't aware of the author making it. It was caused by a relatively big refactor in Jetpack 4.2 that will require a tweak (aimed for shipping next week) and some minor changes on WP.com.

The refactor reveals a handful of bugs—like this—but puts us in a stronger position for a more robust system for the future.

Appreciate everyone's patience on this. Crossing fingers, the only action needed will be to update JP once 4.2.3/4.3.0 is out.

#6 @kraftbj
3 years ago

First commit dropped on dotcom to, at least, hide the "by" line on e-mails under this condition to make it seem less broken while we work on ensuring the author information is provided.

This ticket was mentioned in Slack in #meta by sergey. View the logs.


3 years ago

#8 @ocean90
3 years ago

  • Summary changed from Missing post author name and avatar in email notifications from Polyglots blog to Missing post author name and avatar in email notifications from make blogs

@kraftbj w.org is now using 4.3.1 but https://make.wordpress.org/core/?p=19593 was still send without author data.

#9 @kraftbj
3 years ago

@ocean90 I noticed that too and been looking into it. Don't have anything notable yet. Thanks for the ping!

#10 @kraftbj
3 years ago

The working hypothesis at this point is a random w.org sandbox that hasn't svn up the jetpack external is polluting the options table with an older option. WP.com attempts to use methods consistent with the older version, which no longer apply to 4.3.1 (4.2+ to be exact), while skipping the failsafe code we put in place to specifically catch the author.

We're going to try to change things up a bit to work around this pending getting all of the sandboxes up to date.

#11 @samuelsidler
3 years ago

  • Keywords close added

I'm pretty sure this is fixed now. Has anyone seen it in a while?

#12 @SergeyBiryukov
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.