WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 9 months ago

#1981 closed defect (fixed)

Forums: Escaped entities in notification subject

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Notifications from this topic have the following subject:

[Форумы поддержки] Как заставить работать "js" скрипты

The " entities should be regular quotes, like in the topic itself:

[Форумы поддержки] Как заставить работать "js" скрипты

Change History (7)

#1 @SergeyBiryukov
4 years ago

If I edit the topic in the admin, the Title field shows entities as well: Как заставить работать "js" скрипты (tested with a topic created 4 months ago, as well as a newly created topic). Does not happen on front end.

Could not reproduce that on a regular (non-bbPress) WordPress install. If I enter a title with quotes there, quotes are not converted to entities.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #meta by obenland. View the logs.


2 years ago

#4 @obenland
2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Looks like this was fixed since the bug was reported.

#5 @Clorith
2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm still getting the encoded subject lines here, perhaps it's dependent on what generated the notification email?

The one i just received was created by subscribing to a plugin from its support forum overview

#6 @tellyworth
23 months ago

This probably should be reported upstream to bbPress.

#7 @dd32
9 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

I think this has been fixed with the bbPress 2.6 upgrade. I can't duplicate it with regular Subscription emails.

Marking as fixed.

To: noreply@wordpress.org
Subject: [WordPress.org Forums] [Test Plugin 3] This is a “topic”
Date: Wed, 18 Mar 2020 05:35:36 +0000
From: "WordPress.org Forums" <noreply@wordpress.org>

If still experiencing it, please include the email specifics/headers/screenshot/etc.

Note: See TracTickets for help on using tickets.