WordPress.org

Making WordPress.org

Opened 3 years ago

Last modified 8 months ago

#1981 reopened defect

Forums: Escaped entities in notification subject

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Notifications from this topic have the following subject:

[Форумы поддержки] Как заставить работать "js" скрипты

The " entities should be regular quotes, like in the topic itself:

[Форумы поддержки] Как заставить работать "js" скрипты

Change History (6)

#1 @SergeyBiryukov
3 years ago

If I edit the topic in the admin, the Title field shows entities as well: Как заставить работать "js" скрипты (tested with a topic created 4 months ago, as well as a newly created topic). Does not happen on front end.

Could not reproduce that on a regular (non-bbPress) WordPress install. If I enter a title with quotes there, quotes are not converted to entities.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #meta by obenland. View the logs.


14 months ago

#4 @obenland
14 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Looks like this was fixed since the bug was reported.

#5 @Clorith
14 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm still getting the encoded subject lines here, perhaps it's dependent on what generated the notification email?

The one i just received was created by subscribing to a plugin from its support forum overview

#6 @tellyworth
8 months ago

This probably should be reported upstream to bbPress.

Note: See TracTickets for help on using tickets.