WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 22 months ago

#2022 closed defect (fixed)

Issue with theme rating bar

Reported by: hardeepasrani Owned by: coffee2code
Milestone: Priority: normal
Component: Theme Directory Keywords: has-patch commit
Cc:

Description

If there is a theme with 2 5-star reviews, like this theme: https://wordpress.org/themes/vega/

The rating bar is overflowing, with the width of 200%.

Can't confirm for plugins.

Attachments (2)

Rating.png (339.4 KB) - added by hardeepasrani 3 years ago.
2022.patch (573 bytes) - added by gk.loveweb 22 months ago.

Download all attachments as: .zip

Change History (10)

@hardeepasrani
3 years ago

This ticket was mentioned in Slack in #themereview by hardeepasrani. View the logs.


3 years ago

#2 @SergeyBiryukov
3 years ago

Previously: #897, #997.

#3 @SergeyBiryukov
3 years ago

Like in #997, .counter-back { overflow: hidden; } would probably fix it.

Can't reproduce the issue at the moment though, the rating is displayed correctly for me in Chrome on Windows 10.

#4 @hardeepasrani
3 years ago

@SergeyBiryukov Yup, it's working just fine on FF now as well. Could be a cache issue, I suppose.

#5 @SergeyBiryukov
3 years ago

A CSS fix still seems worth adding, just in case.

@gk.loveweb
22 months ago

#6 @gk.loveweb
22 months ago

  • Keywords has-patch added

Hi @SergeyBiryukov @hardeepasrani I have attached the patch, could you please check and let me know if need any changes.

#7 @SergeyBiryukov
22 months ago

  • Keywords commit added

Can no longer reproduce the issue, but adding a CSS fix just in case a caching glitch happens again wouldn't hurt.

Otherwise, seems like a worksforme, same as #897.

#8 @coffee2code
22 months ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 5699:

WordPress.org Themes: Prevent rating bars from overflowing their container.

The overflow has happened occasionally and briefly due to caching.

Props gk.loveweb, SergeyBiryukov.
Fixes #2022.

Note: See TracTickets for help on using tickets.