WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 15 months ago

#2027 closed defect (reported-upstream)

Saving name in Japanese characters results in "???"

Reported by: Nao Owned by:
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: needs-patch
Cc:

Description

Steps to reproduce:

  1. Go to your Edit Profile page within a WordCamp.org site.
  2. Type in some Japanese characters in any of the name fields. e.g. 高野直子
  3. Update profile (save).
  4. Check the name field - each character is saved as a question mark.

Attachments (2)

profile.png (22.1 KB) - added by Nao 5 years ago.
profile-garbled.png (20.5 KB) - added by Nao 5 years ago.

Download all attachments as: .zip

Change History (12)

@Nao
5 years ago

@Nao
5 years ago

#1 @iandunn
5 years ago

  • Owner set to iandunn
  • Status changed from new to accepted

I was able to reproduce this.

#2 @Takahashi_Fumiki
4 years ago

#2746 was marked as a duplicate.

#3 @iandunn
4 years ago

  • Owner iandunn deleted
  • Status changed from accepted to assigned

This ticket was mentioned in Slack in #meta-wordcamp by iandunn. View the logs.


22 months ago

This ticket was mentioned in Slack in #meta-wordcamp by casiepa. View the logs.


18 months ago

#6 @dd32
18 months ago

Users really shouldn't edit their User profile via WordCamp (But I realise the need to, since most organisers might not know where else to change their Display Name, etc), but disabling that page is probably more trouble than it's worth.

This would probably be fixed by my recent charset HyperDB fixes once ported to WordCamp.

Last edited 18 months ago by dd32 (previous) (diff)

This ticket was mentioned in Slack in #meta-wordcamp by ryelle. View the logs.


15 months ago

#8 follow-up: @ryelle
15 months ago

@dd32 Do you know if the HyperDB changes you mentioned above were ported to WordCamp.org?

I'm still seeing this bug, and we had another report of the name "Levänen" not displaying correctly (not totally sure if it's the same issue).

#9 in reply to: ↑ 8 @dd32
15 months ago

Replying to ryelle:

dd32 Do you know if the HyperDB changes you mentioned above were ported to WordCamp.org?

They haven't been ported to WordCamp.org - In order to do that, WordCamp needs to drop the public HyperDB plugin in favour of the WordPress.org variant.
In my testing, it was a drop-in replacement, but I wasn't willing to change it at the time due to inability to test some changes.

#10 @dd32
15 months ago

  • Resolution set to reported-upstream
  • Status changed from assigned to closed

This ticket has been moved to GitHub https://github.com/WordPress/wordcamp.org/issues/590

Note: See TracTickets for help on using tickets.