WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 2 years ago

#2029 closed defect (fixed)

Issue with user 'Logout' from https://core.trac.wordpress.org/ site

Reported by: Debabrata Ghosh Owned by: nacin
Milestone: Priority: normal
Component: Login & Authentication Keywords:
Cc:

Description

'Logout' is not working in https://core.trac.wordpress.org/ site.

Attachments (1)

2029.png (120.3 KB) - added by Debabrata Ghosh 3 years ago.

Download all attachments as: .zip

Change History (9)

@Debabrata Ghosh
3 years ago

#1 @SergeyBiryukov
3 years ago

Confirmed. It performs a chain of 302 redirects:

  1. Location: https://wordpress.org/support/bb-login.php?action=logout
  2. Location: https://login.wordpress.org/?redirect_to=https://core.trac.wordpress.org/
  3. Location: https://core.trac.wordpress.org/

#2 @Otto42
3 years ago

Redirecting to bb-login.php is no longer valid, since the old support forums are not used. The redirect needs to be changed to logout from login.wordpress.org.

This ticket was mentioned in Slack in #meta by otto42. View the logs.


3 years ago

#6 @ocean90
3 years ago

In 4120:

WordPress.org SSO: Add /logout path.

This path is used for non-WordPress systems like Trac. It displays an "Are You Sure" message to confirm the logout action.

See #2029.

#7 @ocean90
3 years ago

  • Owner set to nacin
  • Status changed from new to assigned

@nacin Can you please change the Apache redirect so it uses https://login.wordpress.org/logout/?

#8 @ocean90
2 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.