WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#2034 closed defect (fixed)

Changes in User Settings at https://translate.wordpress.org/settings are discarded

Reported by: pixolin Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

On https://translate.wordpress.org/settings I try to change the "Number of items per page" but after entering another numeric value and clicking the button "Change Settings" my changes are discarded and the old values are shown. Same applies for all other two settings in that form. Using a different browser doesn't change anything.

Change History (7)

#1 @SergeyBiryukov
3 years ago

Confirmed.

#2 follow-up: @ocean90
3 years ago

  • Keywords reporter-feedback added

I can't reproduce this issue. Do you see anything wrong with https://github.com/GlotPress/GlotPress-WP/blob/2.1.0/gp-includes/routes/settings.php#L29-L64?

#3 in reply to: ↑ 2 @pixolin
3 years ago

  • Keywords close added; reporter-feedback removed
  • Resolution set to worksforme
  • Status changed from new to closed

I just looked again and settings menu now seems to be back working normally.

I switch workflow to "close", right?

#4 follow-up: @SergeyBiryukov
3 years ago

  • Keywords close removed
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Still doesn't work for me:

  1. I change "Number of items per page:" from 120 to 100 and click Change Settings.
  2. After a page refresh, the value is still 120.

Latest Chrome, Windows 10.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#5 in reply to: ↑ 4 @pixolin
3 years ago

Replying to SergeyBiryukov:

Still doesn't work for me:

Ups, sorry, made the wrong assumption it would work for everyone now.
Everything fine for me at the moment.

#6 @SergeyBiryukov
3 years ago

Same issue on Rosetta's Translation Editors page:
https://ru.wordpress.org/wp-admin/admin.php?page=translation-editors

If I change Number of items per page in Screen Options from 20 to 100, the change is not saved.

#7 @ocean90
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [dotorg12451]:

Delete user data in the 'users' cache group on meta data changes.

We have to do this because bbPress 1.x uses BackPress which appends user meta to the user object and stores it in the 'users' cache group, see https://backpress.trac.wordpress.org/browser/branches/bbpress-1.0-backpress/includes/class.wp-users.php?marks=467#L427.
WP_User::init() allows to initialize a new user object with any arbitrary data. In this case it will be bbPress'/BackPress' outdated user meta.

WordPress uses a custom cache group for meta data so it doesn't delete the data in the 'users' cache group by default.

This plugin can be removed once all bbPress 1/BackPress-reliant stuff is gone.

Fixes #meta2034, #meta1980.

Note: See TracTickets for help on using tickets.