WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#2057 closed defect (worksforme)

PTEs can't be added to more than one project

Reported by: petya Owned by:
Milestone: Priority: normal
Component: International Sites (Rosetta) Keywords:
Cc:

Description

A new bug, really fun one - when I add a user as a PTE for one project (a plugin for example), his PTE access for his other projects disappears.

How I came across it:

  • I tried adding @robertsky_ as a PTE for Jetpack, WooCommerce and Akismet
  • I successfully added him as a Jetpack PTE, confirmed at the Translation Editors Screen (Screenshot: https://cloudup.com/i56UJeO2O08)
  • I tried adding him as a PTE for Akismet and got a success message, but when I went to confirm on the Translation Editor screen, he was only listed as an Akismet PTE (Screenshot: https://cloudup.com/i-Bx0qI9OpS)

There were several 502 Badgateway errors I got before I was able to add him as a PTE for either project.

I tested with another user recently added as a PTE for #fi for the theme Tiny Framework (@lassial358). The same thing happened. When I added the user as a PTE for a second project (Plugin, Add This), the user lost their PTE access to Tiny framework (screens: https://cloudup.com/iQ8PBmDrqV9, https://cloudup.com/ibjY0tcj9zv)

Steps to reproduce:

  • Choose a new user
  • Add them as a PTE for a specific project on a specific locale
  • Confirm they're added as a PTE to the project
  • Add them as a PTE for a second project
  • Check the Translation Editors page to see them listed as a PTE for only the last project you added them to.

Locale: zh_CH (https://cn.wordpress.org)

Browser: Chrome, Version 52.0.2743.116 (64-bit)
OS X, El Capitan Version 10.11.6 (15G1004)

Attachments (4)

Screenshot 2016-09-18 12.45.25.png (260.5 KB) - added by petya 3 years ago.
Screenshot 2016-09-18 12.56.39.png (190.9 KB) - added by petya 3 years ago.
Screenshot 2016-09-18 13.04.37.png (33.7 KB) - added by petya 3 years ago.
Screenshot 2016-09-18 13.07.48.png (30.1 KB) - added by petya 3 years ago.

Download all attachments as: .zip

Change History (5)

#1 @ocean90
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme due to no other reports and I couldn't reproduce it. Feel free to re-open if it's still an issue.

Note: See TracTickets for help on using tickets.