WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 3 years ago

#210 closed defect (worksforme)

Infinite redirect loop for non-ASCII URLs

Reported by: toscho Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

When I try to open this URL …

http://wordpress.org/support/topic/hasn’t-this-become-obsolete

GET /support/topic/hasn%E2%80%99t-this-become-obsolete?replies=1 HTTP/1.1
User-Agent: Opera/9.80 (Windows NT 6.1; Win64; x64) Presto/2.12.388 Version/12.11
Host: wordpress.org
Accept: text/html, application/xml;q=0.9, application/xhtml+xml, image/png, image/webp, image/jpeg, image/gif, image/x-xbitmap, */*;q=0.1
Accept-Language: en,de;q=0.9
Accept-Encoding: gzip, deflate
Cookie: /* removed */
Cookie2: $Version=1
Cache-Control: no-cache
Connection: Keep-Alive
DNT: 1

… I get in Opera 12 a useless response, sending me to the same address with non-ASCII characters encoded in lowercase:

HTTP/1.1 302 Found
Server: nginx
Date: Fri, 18 Oct 2013 08:23:07 GMT
Content-Type: text/html; charset=UTF-8
Connection: close
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Last-Modified: Fri, 18 Oct 2013 08:23:07 GMT
Cache-Control: no-cache, must-revalidate, max-age=0
Pragma: no-cache
Location: http://wordpress.org/support/topic/hasn%e2%80%99t-this-become-obsolete?replies=1
X-nc: BYPASS lax 250

This continues until my browser has enough.

In Chrome, I don’t get a 302, the correct page is sent instead.

Looks like broken UA sniffing.

Change History (5)

#1 @Otto42
5 years ago

Works fine in Opera 25.0 for me.

We don't have any user agent sniffing on this. The URL should be lower case, not uppercase. The redirect is normal for that, but if some browser refuses to actually request it in lower case, then yeah, a loop would be expected.

#2 @toscho
5 years ago

The second redirect is in uppercase. It switches between uppercase and lowercase with no end. I am using Opera Presto (version 12), because Chromium based browsers are inaccessible for me, and it is the only browser in which everything in the WordPress admin UI is keyboard accessible. I cannot switch.

Last edited 5 years ago by toscho (previous) (diff)

#3 @samuelsidler
4 years ago

Opera 12 is no longer supported by Opera, as best I can tell. Thus, if this is an issue with the browser, it's not one that will ever get fixed. On the whole, Opera's desktop browser share hovers at around 1-1.5% (depending on who you ask) and a very small segment of them are using Opera 12 – which, again, is no longer supported. I also don't believe we have any UA sniffing that would affect Opera.

Suggesting wontfix.

#4 @SergeyBiryukov
4 years ago

I used to get a similar redirect loop with non-ASCII URLs (any topic on https://ru.forums.wordpress.org/) when I'm logged out, and the URLs don't have the ?replies=X suffix. Happened in latest Chrome and Firefox.

It's not consistent though, I can't reproduce it at the moment. Sometimes a topic that caused a redirect loop can be opened if I try again in a few minutes.

#5 @ocean90
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.