WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2164 closed defect (fixed)

Support Theme: Pagination on profiles pushes content left

Reported by: Clorith Owned by: coffee2code
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Looking at topics and posts created in a profile the float for the bbp navigation causes things to be pushed to the left

Topics:
http://imgur.com/wftYWx0.png

Posts:
http://imgur.com/rumvZCx.png

Seems caused by a float: right; in https://wordpress.org/support/wp-content/themes/pub/wporg-support/sass/site/_bbpress.scss:128

For reference here's the replies page with the float back at float: nonefrom the bb-base style:

http://imgur.com/IcDROIP.png

Change History (6)

#1 follow-up: @netweb
3 years ago

Should be similar to this:

https://cldup.com/ZwP8pWSCzW.png

Also the headers on each page (similar to the Viewing 8 discussions of 28 total above:

  • Topics header: Viewing 15 topics - 1 through 15 (of 20 total)
  • Replies header: Viewing 15 posts - 1 through 15 (of 1,254 total)

The replies header is there, topics header is not, topics were removed in [3898]

#2 @SergeyBiryukov
3 years ago

  • Summary changed from Forum Theme: pagination on profiles pushes content left to Support Theme: Pagination on profiles pushes content left

This ticket was mentioned in Slack in #forums by clorith. View the logs.


3 years ago

#4 @coffee2code
3 years ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 4284:

Support Theme: Fix display of user topic and reply listings due to float of pagination controls.

Props Clorith.
Fixes #2164.

#5 in reply to: ↑ 1 ; follow-up: @coffee2code
3 years ago

Replying to netweb:

The replies header is there, topics header is not, topics were removed in [3898]

@netweb: I'm not clear what you're saying here. That the .bbp-pagination-count content is blank/missing in certain views whereas the .bbp-pagination-links is always present? If so, that sounds like it should be opened as a separate issue.

#6 in reply to: ↑ 5 @netweb
3 years ago

Replying to coffee2code:

Replying to netweb:

The replies header is there, topics header is not, topics were removed in [3898]

@netweb: I'm not clear what you're saying here. That the .bbp-pagination-count content is blank/missing in certain views whereas the .bbp-pagination-links is always present? If so, that sounds like it should be opened as a separate issue.

This doesn't make sense to me either this morning ;)

As part of the initial forums switch to bbPress 2.x, the forum topics pagination counts were removed for performance optimization, see /support-forums/inc/class-hooks.php?rev=3898#L9 , I was expecting to see this on the users profile though, I'll create a new ticket for this.

Note: See TracTickets for help on using tickets.