WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 6 years ago

#217 closed defect

URL's in [sourcecode] shortcode makeclickable() on 'make'

Reported by: netweb Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

Via https://github.com/Viper007Bond/syntaxhighlighter/issues/27

Take a look at http://make.wordpress.org/core/handbook/automated-testing/#installation

Code being used in the WordPress blog post:

[sourcecode language="bash" autolinks="false"]
$ svn co http://develop.svn.wordpress.org/trunk/ wordpress-develop
$ cd wordpress-develop
[/sourcecode]

Resulting Code Display Output:

$ svn co <a href="http://develop.svn.wordpress.org/trunk/" rel="nofollow">http://develop.svn.wordpress.org/trunk/</a> wordpress-develop
$ cd wordpress-develop

Expected Code Display Output

$ svn co http://develop.svn.wordpress.org/trunk/ wordpress-develop
$ cd wordpress-develop

Comment from @viper007bond on GitHub Issue

autolinks controls the highlighter and basically toggles making URLs clickable in the final render. It's entirely client-side.
This looks like make_clickable() at work but I can't reproduce this though. I copy/pasted the whole source code from the handbook into my 3.7 test install and it worked as expected. Perhaps this is exposing a bug in some code custom to WP.org. Hmm..

Change History (3)

#1 @viper007bond
6 years ago

In short, there shouldn't be an <a> inside of the <pre>. My plugin processes it's shortcodes early to avoid this exact kind of thing.

#2 @kpdesign
6 years ago

There is a ticket in core Trac that addresses this issue, with a patch that will fix core so this doesn't happen.

I tested it earlier today for the exact issue you're seeing in the handbook, and the patch will fix it: http://core.trac.wordpress.org/ticket/23756#comment:19

Once the patch is reviewed and committed, this issue will be resolved. Recommend closing this ticket.

Last edited 6 years ago by kpdesign (previous) (diff)

#3 @netweb
6 years ago

  • Status changed from new to closed

Awesome :) Agreed, closing as duplicate: #WP23756

Note: See TracTickets for help on using tickets.