WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2172 closed defect (duplicate)

Support Theme: 3 up forums list needs consistent CSS units

Reported by: bcworkz Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords: ui-feedback has-screenshots
Cc:

Description

To prevent potential clipping as shown in attached screenshot, (the "View forum >" links in two instances) the individual div heights should be a multiple of font height and line height properties and use the same units.

Right now font height is 0.8rem and line height is 1.5, which may be fine, but the div height is 200px. The units here should match the font height, i.e. rem. As things stand, I suggest 10.8rem (0.8 * 1.5 * 9) is a better div height than an arbitrary pixel height. This accounts for variances in browser and user provided fonts and sizing.

Of course the final rem height would need to be adjusted once the forum titles and descriptions are finalized. Further accommodation may be needed due to different lengths of translated content.

Attachments (1)

clipped.jpg (34.2 KB) - added by bcworkz 2 years ago.
Clipped links on forums landing page

Download all attachments as: .zip

Change History (4)

@bcworkz
2 years ago

Clipped links on forums landing page

#1 @Clorith
2 years ago

We could probably solve this in a much cleaner fashion by using flex (and maintain BC for older browsers if we want with flexibility), we could then do away with the fixed height altogether and not have to worry about font sizes and the likes.

This ticket was mentioned in Slack in #forums by sergey. View the logs.


2 years ago

#3 @SergeyBiryukov
2 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

This appears to be resolved in [4693], so closing as a duplicate of #2390.

Feel free to reopen if there's still an issue.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.