Making WordPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 14 months ago

#219 closed task (blessed) (fixed)

WordCamp.org: Enable MP6 network-wide

Reported by: kovshenin's profile kovshenin Owned by:
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: has-patch
Cc:

Description

How about we enable MP6 on WordCamp.org?

Change History (9)

#1 @iandunn
11 years ago

I don't see any reason why not. Any objections?

#2 follow-up: @nacin
11 years ago

Just FYI, it's about to be merged into trunk.

#3 in reply to: ↑ 2 ; follow-up: @samuelsidler
11 years ago

Replying to nacin:

Just FYI, it's about to be merged into trunk.

wordcamp.org runs the latest tag. In this case, 3.7.1...

#4 in reply to: ↑ 3 @nacin
11 years ago

wordcamp.org runs the latest tag. In this case, 3.7.1...

Can this be changed to the branch?

#5 @iandunn
11 years ago

We were running the branch up until last month; but after the get_allowed_mime_type() bug broke images across the network, @jenmylo recommended we switch to the latest tag instead.

The team discussed it and decided that the benefits of running the branch were outweighed by the risk of organizers seeing WordCamp.org as unstable and setting up their own, independent sites.

#6 @iandunn
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Done.

This ticket was mentioned in PR #220 on WordPress/wporg-main-2022 by @adamwood.


14 months ago
#7

  • Keywords has-patch added

The regression is caused by new Modal styles introduced in the @wordpress/components package.

This PR adds style overrides which are compatible with both the local dev env (WP 6.1.1, Gutenberg 15.4.0) and prod (WP 6.3-alpha-55582, Gutenberg 15.1.0)

Fixes #219

### Screenshots

## Sandbox (prod versions)

| Desktop | iPad | Mobile |

|

| https://i0.wp.com/user-images.githubusercontent.com/1017872/227390264-ef06f320-8bd3-4e90-98cd-7a10212d0976.png | https://i0.wp.com/user-images.githubusercontent.com/1017872/227390289-a5d7ac61-2232-4691-a285-3ad5fc27d968.png | https://i0.wp.com/user-images.githubusercontent.com/1017872/227390316-e6e20618-5f64-4fff-8001-77bf251062f7.png |

## Local

| Desktop | iPad | Mobile |

|

| https://i0.wp.com/user-images.githubusercontent.com/1017872/227390423-19bf21e2-1a80-42a2-8abd-c95824ac87c2.png | https://i0.wp.com/user-images.githubusercontent.com/1017872/227390479-a6e67dd4-ebf4-4080-abb9-3bdba4e7d409.png | https://i0.wp.com/user-images.githubusercontent.com/1017872/227390463-e338649a-dcb7-4359-847b-b1d0b190ac24.png |

### How to test the changes in this Pull Request:

Test locally or in sandbox

  1. Navigate to /download
  2. Click the 'Get WordPress...' button
  3. Dismiss the download
  4. View the modal and check the layout, including different screens sizes

This ticket was mentioned in PR #222 on WordPress/wporg-main-2022 by @adamwood.


14 months ago
#8

Reverts WordPress/wporg-main-2022#220

This ticket was mentioned in PR #223 on WordPress/wporg-main-2022 by @adamwood.


14 months ago
#9

Reverts WordPress/wporg-main-2022#222

Note: See TracTickets for help on using tickets.