WordPress.org

Making WordPress.org

Opened 14 months ago

Closed 13 months ago

Last modified 13 months ago

#2213 closed defect (fixed)

Coming Soon page shows broken admin bar for logged in users

Reported by: ryelle Owned by: iandunn
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: commit
Cc:

Description

The coming soon page was designed for logged out users, so the admin bar was not taken into account - a "logged in user" was assumed to be the site organizer (who passes through into the site). Users might be logged into the wordcamp network, but not site admins, so they should see both the coming soon page and the admin bar.

The CSS is not loaded for the admin bar, thus it just dumps out links in the page's footer. See attachment for broken-looking page.

Patch incoming to re-add the CSS for logged in users.

Attachments (2)

FireShot Capture 003 - WordCamp Torino - https___2017.torino.wordcamp.org_#wp-toolbar.jpg (192.8 KB) - added by ryelle 14 months ago.
coming-soon-ab.diff (638 bytes) - added by ryelle 14 months ago.

Download all attachments as: .zip

Change History (6)

#1 @ryelle
14 months ago

  • Keywords has-patch added

#2 @iandunn
13 months ago

  • Keywords commit added; has-patch removed
  • Owner set to iandunn
  • Status changed from new to accepted

The patch looks great, thanks Kelly! Adding this to my merge list.

#3 @iandunn
13 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 4345:

WordCamp Coming Soon Page: Enqueue admin bar styles for logged-in users

Fixes #2213
Props ryelle

#4 @iandunn
13 months ago

I removed the bits that registered dashicons and admin-bar, since they were already registered in my tests (dequeue_all_stylesheets() only dequeues them), but let me know if you noticed any conditions where they needed to be registered.

Note: See TracTickets for help on using tickets.