WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#2250 closed defect (fixed)

Plugin Directory Admin: Customize Rejection Message

Reported by: Ipstenu Owned by: obenland
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

The current rejection email is a little short and just says that your plugin has been rejected.

While this isn't BAD, it could be better.

This is pretty much what we use as a generic rejection right now.

At this time, we cannot accept your plugins as submitted.

Plugins that reproduce features that are already included in WordPress, without any perceivable additions, such as (but not limited to) duplication of existing short codes ([embed] and [gallery]), widgets (rss feed display), or functionality (adding users), will not be accepted.

We do not permit plugins that we feel to be unethical, such as black or grey hat SEO (including plugins that auto post content). Any plugin related to claims like 'Our plugin will help you earn thousands of dollars' will be rejected, as that behavior is scummy and unwelcome.

Plugins with obfuscated (i.e. hidden or encrypted) code will never be accepted.

While the directory is open for all secure, GPLv2 (or later) compatible plugins, we reserve the right to reject any plugin on any grounds we feel are reasonable, whether or not they are explicitly noted in the guidelines.

If you feel this was in error, please email plugins@… with your plugin attached as a zip and explain why you feel your plugin should be an exception.


Attachments (1)

2250.diff (1.3 KB) - added by Ipstenu 3 years ago.
Rewritten rejection with directions on what to do next!

Download all attachments as: .zip

Change History (6)

#1 in reply to: ↑ description @Ipstenu
3 years ago

Thinking of the reasons WHY we will reject in the future, I think we can trim it down a lot...

Your plugin submission has been rejected from the WordPress.org Directory.

If you believe this to be in error, please email plugins@[wordpress.org] with your plugin attached as a zip and explain why you feel your plugin should be an exception.

@Ipstenu
3 years ago

Rewritten rejection with directions on what to do next!

#2 @Ipstenu
3 years ago

  • Keywords needs-patch added

Attached patch. A quick win.

This ticket was mentioned in Slack in #meta by ipstenu. View the logs.


3 years ago

#4 @obenland
3 years ago

  • Owner set to obenland
  • Resolution set to fixed
  • Status changed from new to closed

In 4474:

Plugin Directory: Improve rejection message.

Props ipstenu.
Fixes #2250.

#5 @samuelsidler
2 years ago

  • Milestone Plugin Directory v3 - M9 deleted

Milestone Plugin Directory v3 - M9 deleted

Note: See TracTickets for help on using tickets.