WordPress.org

Making WordPress.org

Opened 20 months ago

Closed 4 months ago

#2254 closed defect (fixed)

Profile pages send a 404 header

Reported by: cameronjonesweb Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

If you view a user profile (such as mine) the page returns a 404 status even though the page is working fine.

Change History (7)

#1 @SergeyBiryukov
20 months ago

  • Component changed from Profiles to Support Forums

Hi @cameronjonesweb, welcome to Meta Trac! Thanks for the report, I was able to confirm the issue:

cache-control: no-cache, must-revalidate, max-age=0
content-encoding: gzip
content-type: text/html; charset=utf-8
date: Sat, 19 Nov 2016 13:00:21 GMT
expires: Wed, 11 Jan 1984 05:00:00 GMT
link: <https://wordpress.org/support/wp-json/>; rel="https://api.w.org/"
server: nginx
status: 404

#2 @SergeyBiryukov
20 months ago

Could not reproduce on a standalone bbPress install though, appears to be specific to WordPress.org.

#3 @SergeyBiryukov
17 months ago

@ocean90: The 404 code appears to be sent by the server or some dotorg-specific code (can't reproduce it locally), is it something you can take a look at?

#4 @netweb
17 months ago

Related: #bb3047
Previously: #bb1478

#5 @ocean90
17 months ago

@SergeyBiryukov See the linked tickets from @netweb. WP:handle_404() is kicking in. bbPress should probably make use of https://developer.wordpress.org/reference/hooks/pre_handle_404/.

This ticket was mentioned in Slack in #forums by clorith. View the logs.


4 months ago

#7 @Clorith
4 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This has been solved in bbPress, and once 2.6 is released and then deployed to WordPress.org, will be sorted here as well.

Note: See TracTickets for help on using tickets.