WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#2298 closed defect (fixed)

Missing plugin description in 3.0 (encoding issue?)

Reported by: aleksanderkuczek Owned by: tellyworth
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Case: WP Super Cache

old entry: https://wordpress.org/plugins/wp-super-cache/
new entry: https://wordpress.org/plugins-wp/wp-super-cache/

In the new entry from imported data has no description, FAQ and some of the authors missing.

@obenland suggests it might be en encoding issue

Change History (3)

#1 @dd32
3 years ago

Upon looking at this, the following is failing on the contents of the trunk readme in Readme\Parser:

$contents = preg_split( '!\R!u', $contents );

If I remove the utf8 modifier it processes. I assume this is caused by invalid UTF8 in the readme.
The UTF8 specifier is there as it was matching \r or \n as part of a UTF8 multi-byte character previously.

#2 @Otto42
3 years ago

Invalid UTF-8 characters in names at the bottom of the file:

#3 @tellyworth
3 years ago

  • Owner set to tellyworth
  • Resolution set to fixed
  • Status changed from new to closed

In 4486:

Plugin directory: handle invalid UTF8 when parsing and validating readme.

Fixes #2298

Note: See TracTickets for help on using tickets.