WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 3 years ago

#23 closed defect (fixed)

Improve UTF handling of Mass Emails plugin

Reported by: samuelsidler Owned by: coffee2code
Milestone: Priority: lowest
Component: General Keywords:
Cc:

Description

Matt's most recent email to the announce list had curly quotes in it (my fault), which apparently causes some problems. The problems might be iOS specific, but there's clearly character issues in the emails themselves. In my case, the email showed fine on iOS, but there were other reports of incorrect display of those curly quotes: http://twitpic.com/d3m99p

As you can see from the original email, the email sends with a UTF-8 charset, but somewhere along the way was mis-encoded: http://d.pr/n/upsV

Change History (17)

#1 @samuelsidler
6 years ago

I meant to note that Gmail shows the email fine, but on certain OSes will display it poorly. I *think* that only happens if HTML rendering is somehow turned off, but I can't confirm that yet.

#2 @iandunn
6 years ago

These tickets from the Core trac are related, if we want this ticket to serve as the master for all encoding issues: #wp19635, #wp21542, #wp21035

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#3 @pavelevap
6 years ago

  • Cc pavelevap added

#5 @samuelsidler
6 years ago

Another related core ticket: #wp22106.

This ticket was mentioned in IRC in #wordpress-meta by sams. View the logs.


5 years ago

#8 @SergeyBiryukov
5 years ago

Seeing encoding issues in make.wordpress.org notification emails: http://cl.ly/image/3i2V3c2S0F34 (note the  characters). Apparently caused by non-breaking spaces, same as in #195.

This ticket was mentioned in IRC in #wordpress-meta by SergeyBiryukov. View the logs.


5 years ago

This ticket was mentioned in IRC in #wordpress-meta by netweb. View the logs.


5 years ago

#11 follow-up: @netweb
5 years ago

Via @Clorith wp-forums list

"The emails from the make blogs will have the weird symbol (Ã) at times, this is an encoding issue because make.w.org runs an older version of jetpack (it's resolved in the newer versions, I too was puzzled by this a while back and asked George about it)."

Via @Clorith in IRC

"I asked georgestephanis in #WordPress a couple weeks back"

"I was wondering if it was a jetpack bug or my email client, and he said it was encoding that's been patched by now but make ran an older version =)"

@GeorgeStephanis Thoughts?

What version of Jetpack are the make blogs running?

#12 @Clorith
5 years ago

Context from above: http://irclogs.wordpress.org/chanlog.php?channel=wordpress&day=2014-07-07&sort=asc#m4079549

I remembered slightly wrong, he didn't say it was definite, but suspected as much.

#13 @georgestephanis
5 years ago

We've been looking into it. Mike Adams did some testing, and every blog post that gets synced up from the make blogs has character encoding issues, but if we manually trigger a resync, it rectifies itself. It's ... odd, but it also is limited to the make blogs.

Also, version-wise, they're running 2.4.3 -- http://make.wordpress.org/core/wp-content/plugins/jetpack/readme.txt -- Nacin remarked previously that they opted not to upgrade because of unreliability of Jetpack updates, something that we've been loads better on lately, so maybe he'll consider bumping up manually sometimes. ¯\_(ツ)_/¯

#14 in reply to: ↑ 11 @samuelsidler
4 years ago

Actually, all of comment:11 and on is a completely separate issue. The Mass Emails plugin does not run through Jetpack.

This ticket was mentioned in Slack in #meta by sam. View the logs.


3 years ago

#16 @ocean90
3 years ago

  • Owner set to coffee2code
  • Status changed from new to reviewing

#17 @coffee2code
3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

Fixed in [dotorg-11534].

Note: See TracTickets for help on using tickets.