WordPress.org

Making WordPress.org

#2318 closed defect (worksforme)

The new search results are less usable than the old

Reported by: joyously Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

A search for responsive slider on both the old and the new plugin directories gives more results and more relevant results on the old than the new.

The old first page shows 30 plugins, all relevant, and 3 exact name matches first.
The new first page shows 14 plugins, the first 6 are not relevant, and the exact name match is number 8. The other two exact name matches are not on the first page.

The old format provides a link to the author profile.
The new format does not link the author name.

The old format shows when the plugin was updated.
The new format does not show the update time.

The old format puts the rating with the other details, so it's always in the same place.
The new format puts the rating after the title, artificially increasing its prominence and making it harder to compare as the titles are not always the same height.

The old format clearly shows the details at the bottom of each card.
The new format shows unnecessary icons with the details, making it more cluttered to read.

The new format hides the plugin thumbnails on a phone size screen, making it more difficult to tell the plugins apart. The field for active installs is chopped on the right instead of using ellipsis, making it harder to read.

Attachments (2)

Search for responsive slider -old.jpg (1.5 MB) - added by joyously 12 months ago.
Screenshot of search for 'responsive slider' on old directory
Plugin Directory Free WordPr -new.jpg (762.0 KB) - added by joyously 12 months ago.
Screenshot of search for 'responsive slider' on new directory

Change History (8)

@joyously
12 months ago

Screenshot of search for 'responsive slider' on old directory

@joyously
12 months ago

Screenshot of search for 'responsive slider' on new directory

#1 follow-up: @Ipstenu
12 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1692.

#2 in reply to: ↑ 1 @joyously
12 months ago

Replying to Ipstenu:

Duplicate of #1692.

Did you review the Slack archive for the meeting that was when you were on the boat? Alex asked me to open a ticket for this. He wanted specifics about what is wrong with the search.

This ticket was mentioned in Slack in #meta by joyously. View the logs.


12 months ago

#4 @mapk
12 months ago

The old format shows when the plugin was updated.
The new format does not show the update time.

This stat has been proven to be unreliable because it's easily gamed by authors. We've chosen not to show this for now because of this reason and felt that showing which version of WordPress the plugin is compatible with was more important and pertinent.

The old format puts the rating with the other details, so it's always in the same place.
The new format puts the rating after the title, artificially increasing its prominence and making it harder to compare as the titles are not always the same height.

The ratings is the most sought after stat proven by the various user tests we've conducted. So what we've done is help bring that up a bit. Having that rating move up or down slightly based on the title length is really insignificant.

The old format clearly shows the details at the bottom of each card.
The new format shows unnecessary icons with the details, making it more cluttered to read.

No one in any of the user tests that we've conducted had any difficulty reading the stats that had icons next to them.

It's great to see such interest here. One thing that might help with some of these claims is to provide validation such as user tests, etc.

Last edited 12 months ago by mapk (previous) (diff)

#5 @joyously
11 months ago

  • Milestone set to Plugin Directory v3.0
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Totally different from 1692, although the tweaks made for that have changed which plugins show, but not the other usability problems.

#6 @gibrown
10 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

I think with the latest version of the search algorithm that the issues with the quality of the search have been addressed.

https://wordpress.org/plugins-wp/search/responsive+slider/

Thanks for bringing up this specific search query. I used it pretty extensively in my testing. It was a really interesting case of trying to balance number of active installs compared to the text in the title of the plugin. Pretty much all sliders support responsive in some way, so it is a tricky balance.

Going to close this as WFM since it has mostly been fixed in other tickets now (and I don't seem to have other options other than wontfix).

Note: See TracTickets for help on using tickets.