WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2321 closed defect (fixed)

Bring back the Other Notes content from readme's

Reported by: dd32 Owned by: dd32
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

In the simplifying of the directory, we've acknowledged that the trial of the 'Other Notes' section failed overall, and as a result removed that functionality.

We shouldn't simply discard the data though, many plugins make use of it.

I've suggested elsewhere that we should simply suffix the Other Notes content to the end of the Description. Not always the best location for it, but better than discarding it.

Change History (5)

#1 @afragen
2 years ago

Is there some reason for not just keeping it as it's own section? I'm not sure much of what get's put in Other Notes has enough similarity to logically fit appended to Description.

If the problem is the inability to add another section, then appending to Description makes the most sense.

Also, not having a separate Other Notes section gives different more info in View details from plugins.php than on the directory. If the plan would be to remove it from the View details too I'm not sure that's such a good idea either. Pure speculation on my part that the View details might change.

#2 @dd32
2 years ago

We won't be supporting it as a separate section going forward. The majority of plugins which use it that i've seen it's more or less an extension of the description for when they let their description get too-damn-long.

The View Details link in core will also no longer display the Other Notes section, instead it'll be shown as it is in the directory (which right this moment, is not at all).

This is similar to the Installation notes section, which is no longer displayed anywhere at all. Plugins will need to migrate that content over.

#3 @tellyworth
2 years ago

#2287 was marked as a duplicate.

#4 @Ipstenu
2 years ago

I think appending it to the description is fine. We can make a post about it in make/plugins.

#5 @dd32
2 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 4604:

Plugin Directory: Append the Other Notes section to the Description.
This works better with the new plugin directory format. This content was previously hidden.

Fixes #2321.

Note: See TracTickets for help on using tickets.