WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 22 months ago

#2337 closed enhancement (wontfix)

Solving the problem of support questions in product reviews

Reported by: engelen Owned by:
Milestone: Priority: low
Component: Support Forums Keywords: reporter-feedback
Cc:

Description (last modified by SergeyBiryukov)

Disclaimer: I've done a few search queries in Trac and I've looked trough a few pages, but I'm not fully sure whether this has been discussed before (it must have, at least on Slack). #1407 is the closest topic I could find.

I think this is a problem most theme and plugin authors have encountered: users leaving 1-star reviews because they cannot get the plugin/theme to work, do not understand it, or are dissatisfied with the support they have received — or any other reason, really, beyond indicating their actual satisfaction with the product. Reviews, in short, that should have been support topics, and are either used to simply show that they're angry or (worse) to use it as leverage.

See, e.g.:

I would like to use this Trac issue to discussion possible solutions to this problem, and I would happy to participate in the actual implementation of the solution if it ever gets to that point.

One solution that might properly address this problem is to allow users to report reviews as "Not a review", such that they can be reviewed and potentially discarded. A problem with this approach, of course, is the amount of work that would be required in reviewing reported reviews.

Change History (9)

#1 @SergeyBiryukov
3 years ago

  • Description modified (diff)

Previously: #WP24535

#2 @SergeyBiryukov
3 years ago

  • Keywords reporter-feedback added

Hi @engelen, welcome to WordPress Meta Trac! Thanks for the ticket.

This sounds like a duplicate of #1661. There's currently a notice above the review form:

If you are reporting an issue with this plugin, please post in the plugin support forum [link] instead.

Is there something else that could be improved here?

#3 @engelen
3 years ago

Hi @SergeyBiryukov, thanks for the response.

#1661 does indeed touch the subject as well. However, "invalid" reviews are created nonetheless, and can harm the reputation of plugins early in the life cycle. These have not received many reviews, and negative reviews can severely harm their growth. For larger plugins, negative, unsupported reviews can influence reputation as well, and it's difficult to help users who express their problems in reviews at it's not part of a normal plugin author's/team's support workflow.
Summarising: it's undesirable to have non-reviews in the reviews section, and it still happens.

I'm not really suggesting a single solution, but an option would be to allow plugin authors to report reviews on their products that are actually support questions, such that they can be moved to the relevant section. Another way to solve part of the problem would be to hide plugin ratings for plugins with fewer than 5 or 10 reviews.

#4 follow-up: @samuelsidler
3 years ago

Users can (and will) leave so-called reviews that are either invalid or are support issues (or any number of other things). But I don't think we can completely change that. Reviews across the spectrum are like this, including in Amazon, on the App Store, in Google Play, and everywhere else users review products. We can make some improvements around encouraging users to leave quality reviews, but we will not ever solve this problem.

... allow plugin authors to report reviews on their products that are actually support questions, such that they can be moved to the relevant section.

I think it's better to work with the individual user on a given review, if it's a support issue. This kind of behavior helps the user (and potential users) see that the developer is thoughtful even when issues are reported in the wrong place. The user can then change their review, if they see fit. I don't think we should be moving support issues to the support forum without the user specifically saying so.

Another way to solve part of the problem would be to hide plugin ratings for plugins with fewer than 5 or 10 reviews.

I don't think this is helpful as most plugins do not have many reviews.

#5 in reply to: ↑ 4 ; follow-up: @engelen
3 years ago

Replying to samuelsidler:

I think it's better to work with the individual user on a given review, if it's a support issue.

This would be the best solution, but it isn't feasible in — I would say — at least 90% of the cases. The reason for this is that users who leave reviews don't check the "Notify me of follow-up replies via email" box. Thus, any attempt to follow up will lead nowhere. I've replied to many reviews with follow-up questions, and I don't think I've ever received a reply to the questions/answers I pose there.

So the ideal case you describe isn't working in practice. Automatically ticking the "follow-up emails" box would work, but it might not be the best solution from a user's perspective.

I agree that this problem arises on other platforms as well. This should be no reason to not try to address it. Contrary to many other cases, WordPress plugins have dedicated support forums, and they should be used to that end. If we don't want users to post support questions as reviews in the first place, why is there anything wrong with moving them?

Replying to samuelsidler:

Another way to solve part of the problem would be to hide plugin ratings for plugins with fewer than 5 or 10 reviews.

I don't think this is helpful as most plugins do not have many reviews.

This is exactly the point. For plugins with few reviews, an average rating is not informative, especially when individual ratings are far apart. What to say, for example, about a plugin with two five-star ratings and two one-star ratings. Would you say a 3.0 accurately reflects these ratings? I wouldn't. When there's few reviews, the average rating only gives mock-insight, and doesn't inform users. You need more data for an average to make sense.

Last edited 3 years ago by engelen (previous) (diff)

#6 in reply to: ↑ 5 @SergeyBiryukov
3 years ago

Replying to engelen:

Automatically ticking the "follow-up emails" box would work, but it might not be the best solution from a user's perspective.

#6 suggests an option to set the checkbox default value in user profile. It also looks like the checkbox should be enabled when creating a new topic, per comment:4:ticket:6, but that's not the case currently.

On a related note, #2199 introduced a notice that might be helpful here:
This is your review of [plugin/theme name], you can edit your review [link] at any time.

#7 @minnur
22 months ago

#3466 was marked as a duplicate.

#8 @minnur
22 months ago

I feel like this is important and should be reviewed and some kind of action should be taken.

Here are some example of such users who leave negative reviews and do not even try contact developer.

https://wordpress.org/support/users/rvschir/
https://wordpress.org/support/users/jackheape/reviews/ - This user is the most annoying and the way he leaves a review looks like a ransom.
https://wordpress.org/support/users/ktilbury/

#9 @Otto42
22 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Reviews are inherently opinions of their authors. They are free to leave what reviews they like. The reply you leave to a review is more important than the review itself, or even the rating. This isn't ebay, and you do not need a perfect 5 star rating. People see ratings, but they actually do read reviews and the replies you leave to them. Learn to reply to reviews in a professional manner and you will have much fewer issues from negative reviews than you think.

The problem is not the negative reviews, the problem is your view towards them.

Note: See TracTickets for help on using tickets.