WordPress.org

Making WordPress.org

Opened 18 months ago

Closed 5 weeks ago

#2393 closed defect (worksforme)

wp-trac.js should not link mentions in HTML attributes

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Attachments (1)

2393.png (24.7 KB) - added by SergeyBiryukov 5 weeks ago.

Download all attachments as: .zip

Change History (3)

#1 follow-up: @obenland
5 weeks ago

Looks like that was fixed in the past 17 months?

@SergeyBiryukov
5 weeks ago

#2 in reply to: ↑ 1 @SergeyBiryukov
5 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to obenland:

Looks like that was fixed in the past 17 months?

@covers was added to reserved terms in [6501], so that particular example works fine now.

I can still reproduce the issue by replacing @covers with something else, e.g. @test: 2393.png. It looks like [3167] does not always work as expected.

That said, tickets with mentions in titles are rare (I can't find any instances other than #1538 at the moment), so perhaps pursuing a better fix is not worth it.

Note: See TracTickets for help on using tickets.