WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2441 closed defect (fixed)

When logged out the Ideas thread displays replies from alternate threads

Reported by: garrett-eclipse Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Hello,

I was looking at this Ideas thread;
https://wordpress.org/ideas/topic/deselect-categories-in-bulk-edit

When I'm logged in it looks fine, but logged out there's posts shown that are completely irrelevant to this thread so it seems they're pulled from an alternate topic.

Attached screen depicts the issue and compared logged in (left) to logged out (right)

Cheers

Attachments (1)

Screen Shot 2017-01-25 at 11.29.14 AM.png (566.2 KB) - added by garrett-eclipse 3 years ago.
Logged In vs Logged Out view of Ideas thread

Download all attachments as: .zip

Change History (12)

@garrett-eclipse
3 years ago

Logged In vs Logged Out view of Ideas thread

This ticket was mentioned in Slack in #forums by garrett-eclipse. View the logs.


3 years ago

#2 @SergeyBiryukov
3 years ago

  • Summary changed from When logged our the Ideas thread displays replies from alternate threads to When logged out the Ideas thread displays replies from alternate threads

Related: #2203

FWIW, can't reproduce this at the moment (Opera 42, Windows 10), the thread is the same for me whether logged in or logged out.

#3 @garrett-eclipse
3 years ago

Thanks @SergeyBiryukov
I just checked again and no longer see the issue. Could a server cache have been flushed?

#4 @SergeyBiryukov
3 years ago

Weird, now I can reproduce :) The cache definitely seems broken there.

#5 @garrett-eclipse
3 years ago

Hahaha, something weird is going on. It's broken one second then a reload shows no issue. Pretty sporadic so hard to reproduce consistently.

#6 follow-up: @samuelsidler
3 years ago

@xknown: Possibly related to switching to PHP7? We haven't touched the Ideas code in literal years otherwise.

#7 in reply to: ↑ 6 ; follow-up: @xknown
3 years ago

Replying to samuelsidler:

@xknown: Possibly related to switching to PHP7? We haven't touched the Ideas code in literal years otherwise.

It's possible, but I'm unable to reproduce this problem. @garrett-eclipse are there any particular steps I can use to try to reproduce it on my end?

#8 in reply to: ↑ 7 @SergeyBiryukov
3 years ago

Replying to xknown:

It's possible, but I'm unable to reproduce this problem. @garrett-eclipse are there any particular steps I can use to try to reproduce it on my end?

No specific steps, just keep opening the page in different browsers or on different systems.

On the screenshot above, the post on the right has strings from Email Submit plugin's readme.txt file, there's absolutely no reason for it to show up in that Deselect Categories in Bulk Edit thread under normal circumstances.

#9 @xknown
3 years ago

@SergeyBiryukov I was finally able to reproduce it. I just deployed a fix on the dotorg repo -- it should be now fixed.

#10 @SergeyBiryukov
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

@xknown Looks good here, thank you!

#11 @garrett-eclipse
3 years ago

Thank you @xknown & @SergeyBiryukov everything appears to be working now. Appreciated

Note: See TracTickets for help on using tickets.